Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Apple links being hijacked

  • Whenever I click a link to Apple from outside an Apple site - it could be a web page with a link to an app, or a link to a product, or it could be in an email, or it could be a support link in one of Apple's apps - it hijacks me and sends me to the same webpage: for the easypay.ua app in Russian in the App Store. It only happens on the first click and Opera records the link correctly in the history pane. For example, currently in my history pane the title of the page is "easypay.ua in the App Store" and that is where I was sent, but the link is recorded correctly as https://www.apple.com/feedback/apple-podcasts.html and if I click it again I will go to the correct page.

    Using this example, this is what happens. I was in Apple Podcasts on my Mac (Catalina, latest version) and clicked the link to give feedback. That link sent me to Opera (my default browser, Version:72.0.3815.148) which did not send me to the podcast feedback page but to the easypay.ua page. It will do this for the first click of any link to any Apple page or site.

    This happens only in Opera. I have tried other browsers and they do not have this problem. But, Opera is my default browser and it is the one I choose to use. I have reset Opera to default, uninstalled and reinstalled, all the things that I know how to do but nothing helped.

    I have made a screenshot video of how this happens which I'd be happy to share._easypay.ua on the AppĀ Store.jpg

  • You probably have adware or a virus.

    First, check with EtreCheck (fantastic diagnostic app from the Mac app store). Then scan with malwarebytes. You can uninstall either whenever you find what is affecting your system. I found out I had adware this way, even though I never download malicious files. Still not sure how I got it, but removing it fixed a lot of issues with my system.

    I would also recommend backing up your data (passwords, history, etc) to your Opera account, then completely uninstalling Opera and reinstall.

  • @nintendork07 Thank you for your response. Unfortunately I had already taken all those steps before posting here, so I am at a loss as to what to do.

Log in to reply