Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Installation fails with ownerless file "opera.exe".

  • If you want to try an official source, there's always the FTP archive:

    Though I'm uncertain if Opera GX is compatible with Windows 7.

  • @itzthemeow Going by the log, it seems like it is trying to access 2 different directories which actually should be the same

    1. C:\Users\Pa Cyber
    2. C:\Users\PACYBE~1

    Maybe it doesnt work when your Username contains a blank space?
    You could try installing it for "all users" instead (choose "options" in the very first window after starting the installer).

  • I just tried the FTP latest installer and one version back, and they both have the same issue. Installing for all users does not work either 😕

    It looks like the log got further.
    Here's the log of the all users install:

    [1028/] Opera GX installer starting - version 71.0.3770.287 Stable
    [1028/] Command line: "C:\Users\Pa Cyber\Other\Opera_GX_71.0.3770.287_Setup_x64.exe"
    [1028/] Uninstall:0
    [1028/] Silent:0
    [1028/] Run Immediately0
    [1028/] Backend0
    [1028/] Inside package0
    [1028/] Autoupdate:0
    [1028/] Reading Payload
    [1028/] Found full package
    [1028/] Found 3 paths for standalone install mode.
    [1028/] Language not in the available languages list: 
    [1028/] Trying language from system preferred list: en-US
    [1028/] Retrying after adjustments: en-US
    [1028/] Trying language from system preferred list: en
    [1028/] Installer download folder: C:\Users\PACYBE~1\AppData\Local\Temp\.opera\Opera GX Installer Temp
    [1028/] Getting installer UI mutex
    [1028/] Install folder set: C:\Users\Pa Cyber\AppData\Local\Programs\Opera GX
    [1028/] Operation: 1
    [1028/] Initializing installer UI
    [1028/] Stopping the download
    [1028/] Starting the package fetcher
    [1028/] Starting download from
    [1028/] Writing payload to fileC:\Users\PACYBE~1\AppData\Local\Temp\.opera\Opera GX Installer Temp\opera_package_202010280859241\opera_package
    [1028/] Initial request completion
    [1028/] Could not get Content-Length from response: Error (0x13D) while retrieving error. (0x2F76)
    [1028/] Download completed
    [1028/] Install folder set: C:\Program Files\Opera GX
    [1028/] Operation: 1
    [1028/] Accept clicked.
    [1028/] Beginning installation
    [1028/] launching installer backend: "C:\Users\Pa Cyber\Other\Opera_GX_71.0.3770.287_Setup_x64.exe" --backend --install --import-browser-data=0 --enable-stats=1 --enable-installer-stats=1 --launchopera=1 --installfolder="C:\Program Files\Opera GX" --profile-folder --language=en --singleprofile=0 --copyonly=0 --allusers=1 --setdefaultbrowser=0 --pintotaskbar=1 --pin-additional-shortcuts=1 --server-tracking-data=server_tracking_data --initial-pid=6392 --package-dir-prefix="C:\Users\PACYBE~1\AppData\Local\Temp\.opera\Opera GX Installer Temp\opera_package_20201028085924" --session-guid=19439124-26f4-4589-8b1d-0370f82e46e5 --desktopshortcut=1 --wait-for-package --initial-proc-handle=DC05000000000000
    [1028/] Package ready.
    [1028/] Fetching default prefs overrides to C:\Users\PACYBE~1\AppData\Local\Temp\.opera\Opera GX Installer Temp\opera_package_202010280859241\pref_default_overrides with tracking data 
    [1028/] Starting download from GX&version=71.0.3770.287
    [1028/] Starting download from
    [1028/] Initial request completion
    [1028/] Could not get Content-Length from response: Error (0x13D) while retrieving error. (0x2F76)
    [1028/] Download completed
    [1028/] Default prefs overrides fetched successfully
    [1028/] Initial request completion
    [1028/] Download completed
    [1028/] Informing the installer backend that the package is ready
    [1028/] Installer error: Unpack archive operation failed
    Could not lzma unpack, error code: 7
    Cannot unpack the installer
    [1028/] Stopping installer backend (if running)
    [1028/] Handling pending error
    [1028/] Displaying error: "An error occurred while attempting to install Opera!" and don't offer full package
    [1028/] Terminating the controller
    [1028/] Stopping the download
    [1028/] Stopping installer backend (if running)
    [1028/] Stopping installer backend (if running)
    [1028/] Terminating the package fetcher
    [1028/] Stopping the download
  • Uninstall Opera from Programs and Features. You can choose to keep your data if you want.

    Delete all files and folders in "C:\Users\yourusername\AppData\Local\temp".

    Delete "C:\Program Files\Opera GX" if it still remains.

    Delete "C:\Users\yourusername\AppData\Local\Programs\Opera GX" if it still remains.

    Delelte all files and folders in "C:\Windows\temp".

    Unpin and delete any Opera GX shortcuts you have.

    Open up regedit and delete the "HKEY_CURRENT_USER\SOFTWARE\Opera Software" key.

    Download and Open the latter with a text editor to see the sha256sum for the installer. Then, check the sha256 hash of "Opera_GX_71.0.3770.302_Setup_x64.exe" to make sure it's correct.

    Once you're sure the installer file is in tact, launch it, click "options", set "install path" to "C:\Program Files\Opera", set "install for" to "all users", uncheck "import data from default browser" if it's checked, adjust other options and install.

    If that doesn't work, create another user on Windows and try doing an all-user install there just to see if it works.

    Also, test to see if your anti-virus is interfering.

  • New user installation doesnt work for all users, or the usb option. It doesnt show up in programs and features because it never finishes installing.
    Clearing the temp files did not work either. Im honestly confused why this is not working.
    And i dont have an antivirus to interfere with it.

  • I'm going to try and install the standalone USB version in a VM with tiny7, if that doesnt work i dont know what to do...

  • The installation works in the VM, but i used a virtualbox shared folder to move it onto my system, the exe becomes ownerless as soon as its on my system...

    So when i try and copy it over, the opera.exe file becomes ownerless and 0-byte.

  • @itzthemeow Installation started with admin rights? The only option left that I could think of.

  • yes i did

  • I tried it again on a different pc. It's windows 10 this time.
    Same error... (latest installer from the FTP)

  • I have read about this same issue on Visit this site it might help you as well.

  • is there a link to an article about it?