Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Hardware Acceleration yes or no?

  • I have a new Windows 10 Chuwi X10 Tablet PC (2-in-1) which has higher specification than my previous machine and in most respects is working well, but I am unexpectedly getting a major problem with streaming, for example YouTube videos, Frequently it is unusable because the display changes to a multi-coloured curtain of slanted stripes. I have tried changing the resolution to a variety of lower settings (as well as cleaning RAM and stopping other programs from running).

    I had no success with this. From way back I recall some advice about Hardware Acceleration being set to 'on' or 'off' but what I have now read I have not understood. How do I tell if HA is 'off' or 'on' with my machine and with Opera, which should it be (what I have read seems self-contradictory), and how do I do it?

    Clarification regarding this would be welcome, plus any other suggestions.

  • @c3h I always have it set to on. Unless you are using a very old and/or weak hardware, specially GPU and CPU, there is no reason to keep it off.

  • Goto the URL opera://gpu to tell if hardware acceleration is on or off for various things. Look at "Video decode" for example. If it's on and you have problems, you can goto the URL opera://flags/#disable-accelerated-video-decode to disable hardware-accelerated video decode (make sure to restart Opera afterwards) to see if it helps. If it doesn't, you can goto the URL opera://settings/system and disable hardware acceleration for all things.

    However, before you disable hardware-accelerated video decode or hardware acceleration in general, goto the URL opera://flags/#use-angle and try different values for the flag (restarting each time).

    At any time, you can goto opera://gpu to check the status of hardware acceleration etc.

  • @burnout426 The problem appears to be resolved, in both Opera and EDGE, by switching off Hardware Acceleration. It may seem odd but I have a vague memory of this when I got my previous PC. Other fixes failed. Video streaming is now working OK

Log in to reply