Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Login Citrix: Wrong password is stored

  • Hello, I noticed this little but annoying problem:
    When I login to my company´s citrix site, there are three entry fields:
    First for username, second for a smartphone-generated one-time PIN, third for the password.

    When I enter the data on page, opera does save the one-time PIN in the second field, but not the password.

    Any way to fix this?

    Regards
    choensmuc

  • How does Chrome handle it? Opera and Chrome are both based on Chromium. The problem could be in Chromium.

    Right-click on each field and choose "inspect" to see what the type attribute value is. Does the third have type="password"? Does the first one have type="username"? What does the pin one have? Do any of them have autocomplete="off"?

  • If your passwords are not saved, you need to change settings. Simply go to Setting > Advanced option > autofill section, and click on the Passwords option. Check saved Opera passwords, and now you will be able to see your password when you log in again.

  • @naheed Do you ate least read the posts before replying to them?

  • @burnout426 Thanks for your answer.

    Chrome does the same. 😕

    I checked the attributes with "inspect". The type for the second and third entry field is set to attribute="password". The problem might be that the third field (for the real password) is named id ="passwd1", while the second one (for the one-time RSA number) is named id="passwd".

    So obviously the browser is led to think the field named "passwd" is the password.
    Dang. Seems to be a tricky one.
    Maybe it´s useless to find a general solution just by logic.

    Perhaps... if there is more than one password-field, the browser could either ask the user, which one to save or just save all password-fields?

    If you want to have a look at the page I´m talking about: it´s www/vapp/vkb/de
    (slashes are dots, of course).

    I think it´s a standard citrix login screen.

  • @choensmuc said in Login Citrix: Wrong password is stored:

    If you want to have a look at the page I´m talking about: it´s www/vapp/vkb/de
    (slashes are dots, of course).

    I just get connection refused for that site.

    Chrome does the same.

    Okay.

    I checked the attributes with "inspect". The type for the second and third entry field is set to attribute="password".

    It's good they have type="password",

    The problem might be that the third field (for the real password) is named id ="passwd1", while the second one (for the one-time RSA number) is named id="passwd".

    What name="" do they have (as opposed to id="" you mentioned)?

    But, the big question is, do you see autocomplete="off" for the third field? If so, that tells the browser not to save it.

    I'm also not sure what's supposed to happen when there are 2 type="password" fields when it comes to saving passwords.

  • @burnout426
    Refused connection? Oh. Don´t know why.

    The name field for both password-fields is "a" followed by a long number of about 15 digits each.
    Both have autovomplete = "off". But the first (one-time) passwors is saved anyway.

    Dang.
    Of course normally there is only one password-field on each page.
    That´s handled very well by opera.

    On my companie´s page there´s a kind of two-factor identification:
    The password I know (which I´d like to save) and the one-time transaction number I get from a special app on my mobile (which is useless to save.
    I think there would be no problem if the passwort field would be the first password-field,
    but alas it´s the second.

    So I think Opera can´t handle this at the moment.

    Is there a way to suggest the idea of the the dialogue-window to the dev-team?
    (if there is more than one password-field, ask the user, which one to save)

    Thanks for your help!

  • You can test https://chrome.google.com/webstore/detail/lastpass-free-password-ma/hdokiejnpimakedhajhdlcegeplioahd in Opera to see what it does for the site. It might work better. (You can turn off Opera's saving of passwords at opera://settings/passwords so you can use just the extension's.)

  • @burnout426 I tried the extension, but no use.

    Do you know how to make suggestions to the dev-team?

  • I forgot though. With Opera's password management, try with https://chrome.google.com/webstore/detail/autocomplete-on/kkffidhhikbopjomeeaihconieppiaan installed in Opera to override autocomplete="off" just to see what happens.

  • @burnout426 Thx.
    I just made post there.

Log in to reply