Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Whatsapp and Facebook messenger keep activating themselves.

  • It started happening to me in normal Opera couple of weeks ago - before that messengers stayed disabled all the time and now Facebook keeps popping up every couple of days.

    Do you have Opera Sync enabled? I suspect it might be another example of Opera Sync feature being broken for years now. It keeps syncing and undeleting bookmarks, I removed, every now and then.

  • i am totally agree with it. Thanks for sharing.

  • This post is deleted!
  • Excellent post and Excellent Explanation. Thanks.

  • 100% agree with this.

  • Come on, man!

    This is an ongoing issue that multiple users have reported and the other threads were closed with no answers.

    Facebook messenger popping up and even opening on launch after having been deselected multiple times is extremely intrusive. Have you forgotten why so many choose Opera?

    Well, hopefully you get this fixed before you lose more users. It's too late for me, I'm off to try Vivaldi and I probably won't ever be back. Shame!

  • @nibake I already gave up on Opera. The whole direction it is going since Chinese buyout is ridiculous. What a shame 😞

  • There's one radical move I did few years ago:

    Block Facebook pool of addresses in your firewall & router.

    [Fig. 1] My way to deal with FB:
    ssox_2127.png.png

    [Fig. 2] FB IPs:
    Opera Snapshot_2021-01-30_130715_10.10.115.60.png

  • Recent Firefox convert (for now) here.

    WhatsApp has appeared on my sidebar on multiple occasions despite my disabling it any any setting that seems possibly related to suggestions/promotions. If there isn't a way to stop this, this is absolutely a deal-breaker. I don't use Facebook or WhatsApp and I certainly don't want them in my sidebar.

  • Same here What's App appeared again on my sidebar hours after update.

    Please fix this Opera Team.

  • @reason said in Whatsapp and Facebook messenger keep activating themselves.:

    I have deactivated Whatsapp and Facebook messenger on the sidebar yet i keep getting messages, about 1 every two days to try them out or to turn on notifications or what have you. I then have to go into settings and disable them again.

    So far my digging through the settings has turned up no additional method for removing these two apps from the sidebar permanently and i gotta say, a feature that keeps trying to force itself on the user despite being purposefully turned off is a real dealbreaker for me. I was enjoying the Opera GX experience until these two apps started to butt in every now and again.

    I am using Windows 10.
    I was not able to find anything that said what version of the browser I have except for:
    "LVL2 (core: 68.0.3618.206)
    Opera is up to date"
    Under the "About Opera" page, which is where i find the version info on other browsers.

    If there was a way to remove those two apps from the sidebar completely or an added functionality such as "Do no remind me again," that would be ideal. Or if there's a buried setting somewhere that I missed that would solve this would also be appreciated.

    Thank you.

    i also agree with this!