Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

White filter on top of youtube videos.

  • @tetika-0
    yeah got annoyed about it too, really dislike it. I haven't figured out how to turn it off automattically yet but inspecting the page element while on youtube when find this style and turning it off in the body works.

    <div class="ytp-gradient-bottom" data-layer="8" style="height: 194px; background-image: url(&quot;data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAADCCAYAAACIaaiTAAABEklEQVQ4T2XI10cFAACF8dvee++67b33uM17b1MkkSSSSBJJJIkkkkQSSSKJ9EfmOw/npfPw8zmBwL/F8IhYE0eJeJNAiUSTRIlkk0KJVEgz6ZTIMJmUyDLZlMgxuZTIM/mUKDCFlCgyxZQoMaWUKDPllKiASlNFiWpTQ4mgqaVEnamnRINppESTaaZEi2mlRJtpp0SH6aREl+mmRA/0mj5K9JsBSgyaIUoMmxFKjJoxSoybCUqEzCQlpsw0JWbMLCXmIGwilIiaeUosmEVKLJllagVWYQ3WYQM2YQu2YQd2YQ/24QAO4QiO4QRO4QzO4QIu4Qqu4QZu4Q7u4QEe4Qme4QVe4Q3e4QM+4Qu+4Qd+/wCa/ysONxfbvQAAAABJRU5ErkJggg==&quot;);"></div>
  • @n0id Thanks for finding the class responsible. I went ahead and made a Tampermonkey script the simply removes this class, code is available to look at on the website (Literally a 1 liner). Requires the Tampermonkey extension.
    https://greasyfork.org/en/scripts/408956-operagx-force-dark-mode-fix-white-overlay-fix

  • I had the same problem and also hated it. I'm using the 'force dark pages' option which causes the white overlay. There are a few ways to fix it: 1. Enable the 'Dark theme' that is native to Youtube or 2. install the 'Enhancer for YouTube' plugin and choose one of it's dark themes. Problem solved! 🙂

  • @tetika-0 so I was having this problem too, that's how I found this page. I really like the "Force Dark Pages" option, but it seems to be causing this issue, at least for me it was. So you can click on "configure" for Force Dark Pages and add youtube to the list of disabled pages. It really handy, and works instantly.

  • The same issue just started to appear with Chrome's dark mode (for some strange reason) and this was the only thread that I could find on the issue. The Tampermonkey script works but its intermittent and sometimes it doesn't remove the white filter.

    Here's an improved script for Tampermoney:

    // ==UserScript==
    // @name        Chrome Force Dark Mode Fix/White Overlay Fix
    // @namespace   namespace
    // @include     *://www.youtube*
    // @description Fixes Chrome Force Dark Mode on YouTube
    // @grant       GM_addStyle
    // @require  http://ajax.googleapis.com/ajax/libs/jquery/2.1.0/jquery.min.js
    // @require  https://gist.github.com/raw/2625891/waitForKeyElements.js
    // ==/UserScript==
    waitForKeyElements (".ytp-gradient-bottom", removeDSclass);
    
    function removeDSclass (jNode) {
        jNode.removeClass ("ytp-gradient-bottom");
    }
    
  • Here's the final improved version:

    // ==UserScript==
    // @name        Chrome Force Dark Mode Fix/White Overlay Fix
    // @namespace   namespace
    // @include     *://www.youtube*
    // @description Fixes Chrome Force Dark Mode on YouTube
    // @grant       GM_addStyle
    // @grant       GM.getValue
    // @require  http://ajax.googleapis.com/ajax/libs/jquery/2.1.0/jquery.min.js
    // @require  https://gist.github.com/raw/2625891/waitForKeyElements.js
    // ==/UserScript==
    waitForKeyElements ("div.ytp-gradient-bottom, div.ytp-gradient-top", removeNode);
    
    function removeNode (jNode) {
        jNode.remove ();
    }
  • The problem is the force dark , but you can go and remove from settings for the specific page "youtube" and then use youtube page setting so it is still on dark theme . hope it made sense what i told ya (sorry for my poor english). if need more help pm me 🦌

  • @koyfontinas how do you remove it from youtube only? i can't figure out how :'[

  • @sodapoppy First, click on the three lines in the top right of the browser (this is directly under the "X" button to close the window). Then find the option for "Force Dark Pages" and click on "Configuration". Then under the "Disable" section, click on "Add". Then just add www.youtube.com and save and close it.

  • @dedmachine force dark mode isnt in the 3 lines, its on the opera://flags page. there's no option for configuring

  • @sodapoppy Click on the "O" in the top left and go to "Update & Recovery" and check for updates. It definitely is an option, but it has a beta label on it. So maybe only recent versions or certain users have access to it.

  • @dedmachine are u using a different version of opera? like the beta or developer one?

  • @sodapoppy Probably using Opera GX, since this area is about Opera GX.

  • @leocg i,, feel very stupid. thanks so much!!