Opera 23 is lagging to load pages

  • Opera 23 is lagging while loading pages. Sometimes it hangs for some seconds or minutes, after it comes back to normal.

  • Not with my setup. I'm using Windows 7. For me the speed is very good. No change from Opera 22. What you describe does not sound normal. Particularly when you talk about lagging for minutes. What's your Operating System.?

  • What kinds of pages?
    And do you have many plug-ins enabled at opera:plugins?

    I'm finding it very fast here (Win8.1, Radeon X1550, with hardware acceleration on). Scrolling may even show the checkerboard sometimes but it doesn't affect the performance at all it's very speedy and smooth. I'm maintaining something between 20 and 30 tabs open today.

  • My system is Windows 8.1. I have just reinstalled Windows. Sometimes Opera does not respond. That sounds more clear?

  • But what software have you installed since then? Is this from an OEM recovery disk or partition or you installed it fresh (because OEMs always include bloatware in their recovery images)? Have you installed the latest graphics card drivers?

  • I reinstalled with Windows 8.1 installtion. I updated graphic card driver.

  • My friend I have no idea what you have done there...

    Really no plug-ins nor add-ons then?

  • I am updating the system, let's wait :). Yes, no addons nor plugins.

  • It is doing pretty fast now.

  • Should I Windows 8.1 (mine is pro) or Windows 7 because the original was Windows 7 Home Premium?

  • Should I Windows 8.1 (mine is pro) or Windows 7 because the original was Windows 7 Home Premium?

    Should you what?

  • Should I 'install' Windows 8.1 Core (mine is pro) or Windows 7 because the original was Windows 7 Home Premium?

    Check this, I made a test opening several tabs and I opened task manager.

  • So you omitted having installed AVG when I asked...? Hmmm...

  • So you omitted having installed AVG when I asked...? Hmmm...

    I didn't suspect AVG was doing that, I am sorry hehe

  • Should I 'install' Windows 8.1 Core (mine is pro) or Windows 7 because the original was Windows 7 Home Premium?

    Well, it depends on you, on which one do you like most.

  • If you're upgrading from Windows 7 to Windows 8, there may be an issue of whether you have the right drivers for your computer. That's something the manufacturer of your computer can tell you. Or they may have drivers that you need to install.

  • I don't have time to install Windows 7, when I have it, maybe I will do it. I have a driver pack, that won't be a problem :)

  • Running Windows 7, recently pages started taking a LONG time to load in Opera 23.0.1522.60.

    I found that, while Opera was trying to load any page, my ability to ping my gateway because timeouts. For example, from a Command Prompt:

    C:> ping 192.168.2.1 -t
    Reply from 192.168.2.1: bytes=32 time=4ms TTL=64
    Reply from 192.168.2.1: bytes=32 time=2ms TTL=64
    ...at this point, I click on an Opera bookmark to go to any website. Right away it becomes:
    Request timed out.
    Request timed out.
    Request timed out.
    Request timed out.
    ...at this point, I stop Opera from trying to load the page; right away the gateway starts responding:
    Reply from 192.168.2.1: bytes=32 time=3ms TTL=64
    Reply from 192.168.2.1: bytes=32 time=2ms TTL=64
    Reply from 192.168.2.1: bytes=32 time=2ms TTL=64
    Reply from 192.168.2.1: bytes=32 time=3ms TTL=64

    I played with several settings and found the culprit. Unchecking the "Use hardware acceleration when available (requires Opera restart)" option and restarting Opera gives me back the Opera that I know and mostly love.

    I don't know why this behavior started recently, but I imagine it's from a recent update since my Internet and VPN connections are the same.

  • Windows 8+ is faster than 7 in any PC. The only driver I install is the graphics card one, the latest available of my model (from AMD, NVIDIA or Intel's website). Everything else works out of the box.

  • I uninstalled AVG, using Defender;

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.