Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Caching issue making webmail insecure?

  • I have been having problems with my business webmail over the past few days going intermittently to HTTP instead of HTTPS (i.e. the padlock in the address bar vanishes and gets replaced with a warning triangle). I have chased the webmail provider's support and they said:

    "We have tested but are currently unable to replicate the issue you are seeing, this issue will likely be an issue with caching on your browser, device or network or the browser, device or network itself. In this case I would recommend trying to access the webmail using an alternate browse (sic) and preferably on a separate device and network, such as a mobile using 4G."

    Tried it on Vivaldi and it didn't keep dropping out of secure mode, so that's my temporary solution. However, using Vivaldi full-time for the webmail would mean keeping 3 browsers open at all times and that's more than my computer can cope with. What I need is to get it working in Opera again. How do I fix the caching problem?

  • Are you using Opera's VPN?

    Are you using Opera's adblocker and tracking protection?

    Do you have any extensions installed and if so, have you tried disabling them to see if one is causing the problem?

    If you open up a private window in Opera and log into your webmail there, do you still experience the issue?

    When you're on the site, you can press ctrl + shift + i to open the developer tools. Then, you can switch to the "Application" tab, and click "clear data" in the "Clear storage" section.

    You can also goto the URL opera://settings/siteData, type the domain in the quick-find field and choose "remove all shown".

    You can goto the URL opera://settings/clearBrowserData and clear cached images and files for all time. You might need to do that for history too.

    Do you have the URL to the webmail on your start page? If so, make sure that it's URL is https. Same for a bookmark for the webmail.

    Have you messed with any of the flags at the URL opera://flags?

  • @burnout426 At the moment, not using VPN.

    Using adblocker and tracking protection: that is a basic requirement for a browser.

    Is there an equivalent of the Firefox Safe Mode to check extensions?

    No difference when I open a private window.

    Just tried Developer Tools, but it didn't appear to be using any storage.

    Now trying to clear browser data, but the last time I tried that, it took hours and didn't complete.

    Didn't know opera://flags was a thing.

  • @acaciahoney said in Caching issue making webmail insecure?:

    Is there an equivalent of the Firefox Safe Mode to check extensions?

    Not exactly. But, you can just goto the URL opera://extensions, disable all your extensions, restart Opera and try. Then you can enable again when you're done testing.

    Or, try one of these in a command prompt. Goto the URL opera://about for the "install" path so you know what the correct path to launcher.exe is.

    "%ProgramFiles%\Opera\launcher.exe" "--user-data-dir=%USERPROFILE%\Desktop\Opera Test"
    

    or

    "%LocalAppData%\Programs\Opera\launcher.exe" "--user-data-dir=%USERPROFILE%\Desktop\Opera Test"
    

    You can delete the Opera Test folder after you're done.

    Don't enable the adblocker etc. when you're testing though.

    You can start Opera with the --disable-extensions command-line switch, but I read that it just hides them and they're still active, which wouldn't help for testing.

    Using adblocker and tracking protection: that is a basic requirement for a browser.

    Temporarily disable them though to see if they're causing the problem.

  • @acaciahoney There seems to be some confusion here. The warning triangle badge doesn't mean that the page went to http but that there is at least one non-secure element on the page, what makes Opera to show the page as not being secure, hence the warning triangle showing up instead of the padlock.

  • @leocg OK, what can I do about that, please? Is it a browser issue or a webmail issue?

  • @acaciahoney There isn't much that can be done unless, maybe, check every single email message for non-secure elements.
    And as soon as you get a new message with a non-secure element, the problem will happen again.

    I guess you just will need to get used to it.

  • @leocg That's weird. I get a lot of similar emails from the same senders regularly. Sometimes the padlock is there for them, sometimes the warning sign. And that includes emails where there aren't any remote images. There doesn't seem to be any rhyme or reason to it.

  • @leocg Update: it is not individual emails. Just had it start off with the padlock in the address bar, then go back to a warning sign as I was going through emails. I noted a timestamp for one of the emails I'd checked when the padlock was there (so I could find it again amid other emails with similar subject lines), then went back and checked that email when the warning sign had come back up. The padlock did not return when I checked that email again. Is there anything the browser could be doing to cause this, or do I need to go back to the webmail technical support?

  • @acaciahoney The best thing to do is to just ignore it.

    As you said, once you opened an email message with a non-secure element, the warning badge appeared, since the site was considered not 100% secure. Obviously, just return to an email message where the padlock was still showing up will not make it return.
    You would need to eliminate the problematic message, close the site, close Opera to, maybe, see the padlock on that site again. An this imagining that the cause of the warning is one of the messages.

Log in to reply