Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Prevent Opera from opening new tabs automatically

  • for God's sake, can someone tell me if there is any way to stop the browser from automatically opening new tabs when i click on something?
    Usually they are advertisements,
    The site puts a 'link' masked by an advertisement over the link I want to open and it opens in a new tab, so I have to close this tab quickly before it opens an advertisement that infects my computer, open thousands of other ads or open a porn site that will have a woman moaning in the last volume!

    I want the browser to stop opening tabs automatically. Is there any way?

    Thank you in advance for your attention

  • You can install https://chrome.google.com/webstore/detail/ublock-origin/cjpalhdlnbpafiamejdnhcphjbkeiagm to take care of the ads in the first place.

    Opera itself also has adblocking. Goto the URL opera://settings/privacyProtection. There's also an icon in the address field to turn block on/off for a site.

  • Also, goto the URL opera://settings/content/popups and make sure popups are blocked and make sure nothing is in the allow list.

  • @burnout426
    Hello
    Both these settings and this blocker do not prevent Opera from opening a new tab.
    It blocks the ad, this is working, but it does not prevent the opening of the new tab when clicking.
    If you want to get an idea of what I'm talking about, check out this site
    https://viatorrents.com

    You will see that even if you click on the blank space of the website, it will open a new tab. That's what I want to block

  • I assume this is a Portuguese site, if you go to Settings/Privacy Protection/Manage Lists/ and scroll down to Portuguese (Brazil) and click on that box. Now try your web site that is giving you trouble, and let us know if that worked.

    🙂

  • @bbildman said in Prevent Opera from opening new tabs automatically:

    I assume this is a Portuguese site, if you go to Settings/Privacy Protection/Manage Lists/ and scroll down to Portuguese (Brazil) and click on that box. Now try your web site that is giving you trouble, and let us know if that worked.

    🙂

    Hi, man
    thks for the answer

    Still opening new tabs... Even if the advertisement on the new tab is blocked (which is good anyway), it continues to open a new tab automatically

  • @doido All I can say us that I opened that web site, and sure enough new tabs opened like you said, I right away went to the lists page and clicked the Portuguese list to enable it and the new tabs disappeared. The reason I know about this is that my wife is Russian and she had the same problem, not sure how I figured it out, but when we cllcked on the Russian list, all her extra tabs stopped opening. Make sure you have your adblocker and tracker turned on for this site.

  • @bbildman I can confirm that this works around the problem.

  • Here is how you make the change in current versions of the Opera web browser:

    • Activate the Opera Menu at the top left and select Settings. You may use Ctrl-P alternatively to open the Settings, or load opera://settings instead which does open the preferences as well.

    • Select Advanced and scroll down on the page until you get to the "on startup" section on the Settings page. You may also run a search for startup instead to display only that preference group.

    • Flip the state of Display the start page first under "Retain tabs from previous session" to disable the feature that loads a new tab page whenever Opera starts.

    • I suggest you test the change by closing Opera and opening the browser again. If everything worked out, Opera should just load the tabs of the previous browsing session.

  • @yoyolo

    Your nice long instructions unfortunately are not related to OP problem about viatorrents site behavior 😞

  • @yoyolo said in Prevent Opera from opening new tabs automatically:

    Here is how you make the change in current versions of the Opera web browser:

    • Activate the Opera Menu at the top left and select Settings. You may use Ctrl-P alternatively to open the Settings, or load opera://settings instead which does open the preferences as well.

    • Select Advanced and scroll down on the page until you get to the "on startup" section on the Settings page. You may also run a search for startup instead to display only that preference group.

    • Flip the state of Display the start page first under "Retain tabs from previous session" to disable the feature that loads a new tab page whenever Opera starts.

    • I suggest you test the change by closing Opera and opening the browser again. If everything worked out, Opera should just load the tabs of the previous browsing session.

    Thank you for your instructions. Really quite accurate, but the case is not about when I start Opera, but when I am browsing sites like the one I mentioned above.
    It is not about preventing Opera from opening new tabs at startup, but about preventing Opera from opening new tabs when I click on something. For example, the website above where you click on any point and it opens a tab!

Log in to reply