Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera no longer defaults to google.ca for search bar

  • Opera used to default to Google.ca which was amazingly handy. Since the last update it seems to default to google.com when I type in the combined search/address bar. Is there a way to change it back?

    I've tried adding google.ca to the search engine section in settings, but it still defaults to .com.

  • Re: Opera no longer defaults to google.ca for search bar
    For some reason I am unable to swap the default search engine to google.ca. I would also like to know how to make the google search page go into dark mode.

  • I had to do a system restore and afterwards, my default search engine changed from Google.ca to google.com. I created the google.ca search engine like I did last time but I am unable to make it the default search engine again and I don't know why. Opera is very similar to chrome and it works in chrome could I have been using an extension? Could it be that the feature was removed from the newest version of Opera if that's the case what version would allow me to make google.ca the default search engine? If anyone knows what version or of an extension that would allow me to make google.ca my default search engine I would be very grateful. I don't understand why the search engines have to be .coms because of this many of my searches are irrelevant for my area. I must use Candian search engines otherwise I guess I will have to go back to chrome or firefox and that would truly suck I love opera but I want to make a search in my address bar that will be relevant to my area and not have to open google.ca manually.

  • I am having in a way a similar issue changing the default search browser for the search bar!!! I changed the default browser from google to bing and the search bar still had the G for google on the left side. and when I use the bar it reverted to google. It did not happen like this when I changed my opera settings on the phone, so this must be a bug. I did notice when I searched using the URL link area instead of the search bar when I changed default browser it worked just fine. but on Opera Mobile both work. Search bar and URL search area. For now I am disabling search bar just for ease of acess for myself until they fix the problem.

  • @cowboybub2003 Different issue, so please open a new topic following the instructions.

  • @leocg All due respect, both issues are linked to the exact same default browser setting. Therefore I believe both issues are equally related to the rout cause. However, I will do as you wish.

  • @KoolBreeze420 I guess that now google.com is being used for everyone instead of the local Google site.

    Don't know if it's by design or if it's a bug. The same happen on Chrome and Firefox.