"Unknown" plug in causing Opera to constantly not respond

  • Hello everyone.

    I've had this problem for a number of months now and I'm struggling to find a solution. Opera (12.17, 64 bit) tends to shift into "Not Responding" for thirty seconds or so at a time repeatedly and constantly throughout my browsing experience. I initially thought I may have had a problem with my machine but it's rather new and unlikely to be causing the problem. All other browsers and indeed all other programs work completely fine without this issue ever arising. It's quite literally just Opera and as you can imagine it's very frustrating.

    I had a breakthrough with the issue recently. I installed the latest version of Opera Next (23.0, 64 bit) hoping to evade the problem by just using a later version of Opera and though the problem arose again Opera Next was able to show up an error message that gave me some indication as to the root of the problem. The error message was as follows:

    "The "Unknown" plug in is slowing down your computer and not responding. Would you like to stop the plug in or wait for it to respond?"

    That's not entirely verbatim but you get the gist. I recently had an indication from Opera Next that the "Unknown" plug in might possibly be Shockwave Flash. I recently went to Adobe's website and updated flash to the latest version hoping this would alleviate the problem. At the moment the only way in which I can browse without issue is to hit "Opera:Plugins" and quite literally disable all plug ins in the browser to prevent the error from arising. So my question is this: is there a permanent fix to this issue that doesn't involve disabling every plug in on the system?

    Hope you can help. Thanks for reading.

    Ammar

  • Set the browser to only load plugins on demand, instead of all the time.
    When the problem comes back, you'll know which plugin is guilty because it will be the one you last invoked!
    :-)

  • Does the problem persist if you just disable the flash player plug-in ?.

  • Thanks for the responses everyone! I'm almost a hundred percent certain it's definitely Shockwave Flash causing the problem. I just visited Soundcloud with the Flash plugin disabled and everything was fine. I then enabled the Flash plugin (to listen to the Soundcloud music player) and boom, "Opera is Not Responding". Opera Next is smart enough to know that it's the Flash plugin and tells you with an error message though Opera 12.17 seems none the wiser.

    So Shockwave Flash is causing the "Not Responding" errors. I've visited the Flash website and updated Flash to the latest version but the problem still persists. At the moment the only solution I have is to disable the plugin.

    Anyone know of another way to resolve this issue?

  • Are you sure that you only have one Flash plugin listed in the plugins list?
    It's usually the one in the Windows\System32\Macromed\Flash folder.
    The latest is NPSWF32_14_0_0_145.dll.
    If there are any others in other locations, disable them.
    :-)

  • I have the same problem, there is NPSWF64_14_0_0_145.dll

  • Soundcloud works fine, even if plugins are enables to start automatcially.

    Windows 7 x64 with Opera 12.17 x86.

    May be, the 64bit of Opera or Flash player is the problem.

  • I got the same problem. "The plug in "UNKNOWN" is slowing down your computer" etc...

    Mind you, I've got NO extensions at all.

    Version: 23.0.1522.60
    Update stream: Stable
    System: Windows XP 32-bit

  • i also have this problem. windows 7, 64bit, opera next. only affects youtube, and it will not play certain videos, skip vids in playlists, take around 40 seconds to play after a pause and breif popup of message stated earlier. i have tried everything and finally givein and im setting up firefox again which i do not want.

  • Now I have been having this same problem in Opera constantly for the last few days. This is what I found in the following links:

    C:\Windows\System32\Macromed\Flash
    NPSWF64_14_0_0_179.dll

    C:\Windows\SysWOW64\Macromed\Flash
    NPSWF32_14_0_0_145.dll
    NPSWF64_14_0_0_179.dll

    So which one in which folder should I disable & where do I go to disable them?

  • I think you only need to disable the Shockwave Flash Player plug-in (it's 12.1.3r.163) and enable the Adobe Flash plug-in (14.0.0.179).
    In Opera 23, if you haven't done so already, you click Opera>Settings>Show Advanced Settings. Then Opera>Developer Tools>Plug-ins and disable Shockwave and enable Adobe Flash.
    I don't know what's wrong, but that fixes the problem here.

  • Further note...I just tried it the other way around (enable Shockwave, disable Adobe Flash) and that works also. How and why I have two Flash players, I'm not sure, but maybe one came with Opera and the other came over from Firefox when I switched to Opera. BTW I'm running Win7-64, Opera is x86 32 bit version 23.

  • Posted too soon. With Shockwave enabled and Adobe Flash disabled, Opera crashes at the Shockwave test site

    http://www.adobe.com/shockwave/welcome/

    when you run the test.

  • My bad! It's Shockwave Player 12.1.3.153 that is bad, not Shockwave Flash Player. It confused me because the Adobe Flash shows in the plug-ins list as Shockwave Flash 14.0etc. Shockwave Player is a different animal and is not associated with Flash files (it still doesn't work, anyway). In the Adobe forums, people are reporting problems with other browsers inc. Chrome 36 and IE. Sorry if I added to anyone's problem. BTW, I did a fair amount of web surfing yesterday with Shockwave disabled and didn't run into a single site that needed it.

  • jm444 - tried everything you said still crashes

  • Opera 24 will probably solve those issues.

  • Yep "DNA-24995 [Win] Flash plug-in slowing the computer" is listed in the changelog. By the looks of the changelog and the current date Opera 24 must be almost out already.

  • Disable this in settings, browser plugins, Disable individual plug-ins...
    Adobe Flash Player
    Version: 14,0,0,179
    disabled
    Shockwave Flash 14.0 r0

  • Shockwave Player (not Shockwave Flash) still crashes in Opera 24.

  • Just wanted to add a note here for everyone that the problem seems to be completely gone in Opera 27. Opera 12 still has the problem and has the problem quite severely but Opera 27 runs perfectly without the flash plug-in error.

    I wanted to let everyone know so that they're aware that the easiest solution to this is to just upgrade.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.