Opera 22 open tabs loose connection

  • When I opene several tabs (10 perhaps) then after some time these loose connection (10-100 minutes perhaps) and when trying to refresh page it's going to be blanc with no error message, while there is rotating ring on tab.
    When I open a new tab I can access the same site normally ... for some time only of course. In task manager I see many opera instances running. Looks like tabs are grouped under separate processes and processes just hang.

    When I close Opera and there is not single Opera.exe running and open Opera again with previous tabs, these pages sometimes are working but most often doesn't still display any content. Most famous sites under question are Amazon. com, Am. UK, Ebay.com, Ebay K but also many others.

    Opera 22, Win XP SP3, 2GB RAM no other applications running.
    Any ideas how to fix it?

    Opera 22, Window XP SP3, 2GB memory and now other applications running except perhaps MSIE.

  • FWIW, by design, Opera opens a process for itself, each extension, and each open tab. This is an inherited feature from Chrome/Chromium intended to keep a crash in a tab or extension from bringing down the entire browser. Hence, with a typical installation and multiple tabs open, it's normal to see quite a few Opera processes...

  • But that doesn't explain why Opera sessions loose LAN connection after running for 20 minutes.
    This flaw has got worse today, sessions loose connectivity after 5 minutes and Opera in fact is not usable.

    Therefore I have forced to MSIE now.

  • Is your network that bad? People have previously reported that if the network goes down and comes back up, Opera won't find it without closing and restarting, so that's my guess - that your system reconnects automatically but Opera can't find the new connection.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.