Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera "Not Responding" at Start-Up!

  • Worked fine a couple days ago, tonight, every time I open it, it's just spinning wheels, & Activity Monitor says it's Not Responding, and using 95 to 100% of CPU!!!

    I keep force quitting and re-opening it, and it's not helping, as it just sits there, spinning, using up all my memory & CPU ! Is there anything I can do?

  • @stevenjcee I even downloaded and installed a fresh copy, and it still won't open in usable condition! And I don't even know if the new version is an update or not, since the Opera info in my app folder won't give me the exact version, only saying 67.0! Another mad frustrating quirk....

  • @stevenjcee Same thing on Windows for me, haven't tried on Mac yet, it might be related to the latest update (which they include Workspace on sidebar along others).

    Opera 67.0
    Version: 67.0.3575.53
    
    Opera is up to date
    Update stream: Stable
    System: Windows 10 64-bit
    

    Use opera:about/ to find the precise version you have
    This might help: https://help.opera.com/en/opera36/find-solutions/

    I advice you to report that as a bug if you didn't already, beside that it would be good a representative to respond about this.

    Good luck to us. 🤞
    M.

  • Hi stevenjcee
    same here on Mac.

    so I tried this and it worked for me. ymmv

    1. renamed Opera Beta.app to "Bad Opera Beta.app" app (in apps dir)
      removed shortcut from desktop

    2. downloaded fresh offline Opera Beta dmg from Opera.com

    3. installed fresh Opera Beta package offline

    4. opened fresh Opera Beta app and.... lucky! All my data was preserved
      including my bookmarks, settings, plugins! I went through settings to make sure it was what I wanted.

    Then I renamed the new app to "Opera Beta 68" just for reference

    don't know why this worked .. but it did for me. whew!
    Newbie

  • @herr-matheus Yes, that's the version I have as well, so something must be up with that! I too, hope someone responds, that knows what's going on. As it's now totally unusable....
    I'm still using an older version on my iMac, and it's working OK, it's the new one that's not.

  • I also re-installed an older version on my laptop, and it's working OK, too. It's just the version 67 that was going haywire.

  • Same here. Currently using opera beta as the standard one has become unusable.

  • @herr-matheus said in Opera "Not Responding" at Start-Up!:

    Use opera:about/

    Well, just did and update and now it's “Version:67.0.3575.79”. But still hangs.

    Also noted a change in the sync. I wonder if it's releated.

  • @newbietoopera said in Opera "Not Responding" at Start-Up!:

    renamed Opera Beta.app to "Bad Opera Beta.app" app (in apps dir)

    So the problem already existed in the beta version but you didn't send a bug report to warn Opera about it? And now the “stable” version hangs while the beta version is fixed.

    don't know why this worked .. but it did for me. whew!

    In the name of all the stable users: Thank you! Well done!

    PS: I just send a bug report.

  • This windows fix worked for me on macOS as well.

    My Opera installation fixed itself after about three hours. Note that I didn't actually open any window. Even closed the application. Just let Opera do its thing in the background.

Log in to reply