O24 dev: can't read menus

  • New install of opera 24 developer in Fatdog Linux. Works nicely, except that I can't read tabs, menus, url bar--they all look like .. .... .. ... Websites are fine.
    I have tried opera:config but can't find anything that helps. Does anyone have a suggestion? Thanks

  • What language does your system use?

  • en_US

  • Does Fatdog include a decent selection of TrueType/Freetype fonts?

  • There's a directory (/usr/share/fonts/X11/TTF) which contains about 20 DejaVu**.ttf fonts, but I don't know if Opera is finding them. I linked the folder in ~/.config/opera-developer, but no change. Do you know where Opera24 looks for fonts?
    I should add that Opera 12.16 does not have this issue.
    I'll consult Fatdog's developer about this as well. Thanks for following up.

  • Opera24-developer works normally (after tracking down some libs) in Slacko-64, another 64-bit puppy linux project. So this is apparently a Fatdog issue and I'll pursue it in the Puppy forum (http://murga-linux.com/puppy). Thanks sgunhouse for the support.

  • This is very likely to be font-related, apparently Opera picks up a certain font on your machine that can't display the characters it wants to display. Try uninstalling some font packages or disabling fonts selectively using fontconfig (if you can find out which font is being used). Would be great to hear if you can find out which font is causing this, if any 🙂

  • avl,
    Thanks for the suggestion. Fatdog does not have fontconfig, but I have tried moving, removing, linking fonts, changing languages and font size, etc. without success. I can't find a file or config option that gives Opera a path to fonts.
    I should add that I am using a pre-alpha version of Fatdog 700, so this could be something that's not quite ready in the OS. If I find out anything useful, I'll post it here.

  • Not having fontconfig sounds impossible, then it wouldn't be possible to start Opera. You can try using eg. 'fc-match -v' if you have the fontconfig command-line tools installed to see your default font with all its settings.

  • avl, you're right, I was looking for an executable called fontconfig :oops:

    fc-match -> DejaVuSans.ttf: "DejaVu Sans" "Book"

    fc-match -v -> a long output. Is there anything I should look for that would indicate a problem? Thanks for your patience!

  • Some font that doesn't make sense. The DejaVu fonts should all be fine with Opera, but there are too many fonts for us to guess which you might have. Let me see ... the Bitstream Vera fonts are also good. A common problem is a non-TTF version of Helvetica.

  • Thanks to both of you for the education about fonts. I tried deleting all but DejaVu TTF fonts and then all but 4 of those (verified with fc-list) but the same issue persists.

  • Opera-developer_25.0.1613.1 works flawlessly (so far!) in Fatdog 700. The font issues have disappeared. Thanks, developers!

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.