Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Your connection is not private error message

  • Your connection is not private
    You attempted to reach www.piratefm.co.uk, but the server presented an invalid certificate.

    NET::ERR_CERT_INVALID
    Getting lots of pages showing me this error, it used to happen on Chrome so I switched to Firefox got sick of Firefox so tried Opera loving Opera so far apart from this recurring issue.italicised text

  • @rich-h What version of Opera and what OS? Page loads fine here in Opera developer 67 on Windows 10.

  • @leocg I only got Opera 3 days ago so guessing it's the latest version, windows 7

  • Given that it "used to happen on Chrome", are you now able to use other browsers (IE and Chrome) to correctly access the site on that same computer as your Opera installation? Both of those browsers, like Opera, use Windows own certificate store to verify authenticity of a cert. Then, if you still have Firefox installed, try to correctly access the site in Firefox. Firefox uses Mozilla's certificate store. I'm wondering if perhaps your Windows installation isn't auto-updating its cert store properly, and trying these other browsers might help determine if that's the case.

  • @blackbird71 I can access them fine on Firefox but not Opera or chrome

  • @rich-h That sounds like your chromium-based browsers (Opera and Chrome) either aren't properly accessing Windows' certificate store or else that certificate store is not being properly updated by Windows. Certificate stores (whether in Windows or in the Firefox browser) must be updated periodically to keep track of cert changes. Windows does its update periodically from a Windows server; Firefox does it automatically from a Mozilla server when the browser is activated. Either way, if the updating isn't being done, new certs can't be added or old/defective ones replaced.

    Another thing you should check is whether your Opera/Chrome browsers can access any https websites properly. If so, then access to the cert store is working, but some of the certs in that store would appear to be obsolete or missing - indicating the cert store is not updating properly.

  • @blackbird71 Thanks for the replies, I can access most https websites properly but there are quite a few exceptions, do you know of any work arounds? I checked and I seem to have all available Windows updates installed.

  • @rich-h Do you know if your Windows 7 "update" mechanism is still turned on and working on your system? Windows normally requests its cert updates about once a week through the Windows Update mechanism. I haven't run Windows 7 in some time, but my understanding is that if your certs aren't auto-updating, they can be manually re-installed but it's rather complex. I know in Windows XP, you could easily run a command to force updating, but that's gone away since Vista.

    Something else to try here would be to clear the SSL cache that Windows uses for IE and for browsers that use its cert store, on the chance that some persistent cached certs are corrupted. Turn off the browsers, open Windows Control Panel > Internet Options > Content tab > click the 'Clear SSL State' button > you should get a message "The SSL cache was successfully cleared" > close the panel. Restart the browser and try the site again.

  • @blackbird71 I've kind of done that already using Ccleaner, after watching numerous videos and reading lots of articles on the matter it's obvious it's a common problem and has been for some time, I've thrown in the towel and gone back to Firefox which is a shame because I preferred the privacy and layout of Opera, but hey thanks for trying to help me much appreciated .

  • I know this is an oolldd post, but I had this problem, and I found a solution that worked for me. For anyone who reads this because they had this problem, make sure Operas' built in VPN is turned on. Worked for me, might work for you too.

  • The most common cause of connection is not private is an incorrect date & time set on your PC. Chrome makes sure that your computer's clock matches the clock in a Google server farm, and if it doesn't, will block the connection to HTTPS sites for security reasons.

    To fix your issue, set your computer's clock to the correct current time.

    Go to System Preferences
    Choose Date & Time
    Navigate to the Date & Time tab
    Change the current time to the correct time (accurate to the nearest minute will do).
    Edit: If it's not your computer's fault, it's just a Chrome security feature. Chrome detects malicious activity going on with the site (like malware-laced ads, breach by hackers, etc.) and automatically warns you to protect you if it believes your security or safety might be at risk. If you want to override the warning, just hit Advanced -> Continue to site.

Log in to reply