Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

DNS over HTTPS not working, although enabled

  • Hoping somebody here can help me, I wasn't able to get DoH working on Brave so I've tried on Opera, and was able to find the flag at least and enabled it, but it's still not working for me. Is there something else I should be doing?

    Tested from the https://1.1.1.1/help site, and definitely Enabled under the experiments flag for Secure DNS (DNS over HTTPS)

    Debug Information
    Connected to 1.1.1.1 No
    Using DNS over HTTPS (DoH) No
    Using DNS over TLS (DoT) No

    Thank you

  • @deezy872 It seems that connection to Cloudflare DNS Server is being blocked.

  • @leocg That is what I would have assumed as well, but it seems able to connect

    Connectivity to Resolver IP Addresses
    1.1.1.1 Yes
    1.0.0.1 Yes

    Also did a traceroute and it connected fine.

    Can this still mean it is being blocked?

    Thanks.

  • @deezy872 It was my guess based on your information. Now there are new info, so I don't know.

    Can you use DOH in Chrome?

  • @deezy872 said in DNS over HTTPS not working, although enabled:

    Debug Information
    Connected to 1.1.1.1 No
    Using DNS over HTTPS (DoH) No
    Using DNS over TLS (DoT) No

    how did it suddenly go from NO to YES ?
    you never said what commands you ran besides doing a traceroute but that has nothing to do with dns client itself- for you know it can be the host's own dns setup that can simpy reach cloudflare .. Is there a built in dns service in Opera cause that is the first time i heard of such a thing - I know DNSCrypt has no issues using DOH or DNSSEC but Opera ? Experimental ?? i take it you're using default dns client/service on windows but which version of windows are you using Vista, 7 , 8 , 8.1 or 10 ? Do you have any specific router setups or are you connected to an ISP service gateway directly , does it support ipv6 - how is your firewall setup , did you create any custom rules ?? etc etc

  • I have the same problem.
    It was worked two days ago. Could Windows Update 1909 break DOH?

Log in to reply