Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

crhopera opens virtual keyboard automatically on touchscreen machine running window$ 8.1

  • Hello

    Topic title says by itself. Why this annoying behavior?
    I have no problem on Firefox or IE.

  • If you're going to use a disparaging terms for Opera, at least learn how to spell it correctly. Pathetic is what says it all. And by the way - I have a Lenovo Thinkpad Carbon X1 Touch screen and Opera does NOT open a virtual keyboard and yes... I'm running Windows (not Window$) 8.1. Must be something wrong with your particular set-up. BTW... since you obviously hate Microsoft so much as well as Opera, why do you continue to use both? LOL

  • if you have no solution for the reported situation why did you reply my post? LOL

    Any idea people?

  • Let's get a few other facts ... I presume you must have a laptop with a real keyboard (and presumably a trackpad/touchpad as well)? Second, I presume you must be focusing a text area or the address field (you don't specify which), probably by touching it as I can't imagine using the touchpad or an external pointing device would have that effect? More details would help people like @leushino - and Opera developers - to attempt to duplicate the issue. Possibly even a brand and model on the laptop, in case it is specific to that setup. (I don't have a touchscreen myself and can't possibly try to duplicate the issue and so won't be posting further in this topic except to keep order.)

  • thank you sgunhouse.
    Yes, I focus a text area and the address field area by touching it.
    I use a lenovo notebook model g400s touch.

  • After some experimentation I can confirm that the virtual keyboard "is" brought up when one touches the screen in a Reply and is in Opera. I've tried the same in FF and IE11 and neither produced those results. Granted, I'm also on a Lenovo Thinkpad as I mentioned in my first post so I'm uncertain as to whether this is unique to Lenovo/Opera or not. I'm running Windows 8.1 on 64 bit.

  • thank you leushino.
    I hope some way to disable this annoying virtual keyboard.
    I always prefer use the real keyboard.

  • It would seem to me pointless to show the on-screen keyboard when a physical keyboard is present. If someone were running Opera on a Surface or other x86 tablet and didn't have a keyboard - sure, I could see using the screen keyboard then. But sounds like they may not be checking for a physical keyboard when touch is used to focus the text area.

    For now, you may want to go to https://bugs.opera.com/wizard and file an official bug report ... developers don't always read the forums.

Locked