Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Widevine + H.264 Support on Ubuntu 19.10

  • Hi @nesar77, @miqwalsh, the issue with Widevine looks to be fixed in the latest Opera stable 66.0.3515.103 (DEB/RPM versions) - here you can find two examples by @burnout426 on how to make it works.

  • @l33t4opera Also, I'm slowly gathering/editing https://www.reddit.com/r/operabrowser/wiki/opera/linux_widevine_config to help with this.

  • @burnout426 Yep, it seems quite "smoothly" written, nice job ;-)

  • Copying the *.so file also helps if you have problems with video-playback with Opera 66 based on Chrome/79.0.3945.130. I tried this because I could not find a matching ffmpeg version so far.

  • @thomas-rager upgrade to Opera 67 and libffmpeg is suppplied by it. If you want to use Opera 66 create lib_extra under /usr/lib/x86_64-linux-gnu/opera and copy libffmpeg.so or create a soft link to it.

  • Hi @thomas-rager, you can find the 79.0.3945.130 for example here - if you still need it for Opera 66. There's also 80.0.3987.87, which seems to work for Opera 67.

  • Nothing above helped me, unfortunately.

    All Opera lineup is installed (stable, beta and developer versions), all Chrome lineup is installed as well. In addition, I've installed Vivaldi too. No widevine in Opera (I even put Vivaldi folder in that .json file). Moreover, ffmpeg is broken again (surprisingly it worked out of box in snap package). I'm on Kubuntu 19.10. At work (Kubuntu 18.04) all works fine, no issues with Netflix or Spotify.

    Does anyone know where Opera keeps log files? Several months ago (or years) I found something in the Internet but the knowledge is lost...

  • @johnnyboycurtis

    Thank you it work in Manjaro as well.

  • @thomas-rager said in [Widevine + H.264 Support on Ubuntu Popeyes Survey 19.10](/post/200190):

    Copying the *.so file also helps if you have problems with video-playback with Opera 66 based on Chrome/79.0.3945.130. I tried this because I could not find a matching ffmpeg version so far.

    Ya wait i will tell you exact problem .

  • I was having major 'problems' getting WideVine to function at all under Opera 66 & 67; the method we'd previously used to set absolute paths for the Puppy 'portable' packages via the use of the 'tee' command was no longer working. And then it struck me.....the answer was so simple I could have kicked myself.

    Bearing in mind that Puppy's 'run-as-root' model has been causing us grief for the last four years with the Chromium/'Blink'-based browsers, we run these packages as user 'spot'.....this being a restricted user with the same type of permissions as any normal user in the mainstream distros. Consequently, the whole of a Chromium-based browser's files live in the /root/spot directory.

    For the 'portables', we use the 'readlink' command to set the location variable for the portable's directory, irrespective of its actual location. This allows us to create the browser's profile within that directory, and this all works very well.

    However, regardless of Pup's slightly odd set-up, Opera is still looking in the locations it expects to find Widevine and libffmpeg in, as dictated by the internal coding and the .json files in /opera/resources. Bummer..!

    But the answer, as I said, was very simple.

    Puppy, as part of its 'frugal' install/run method, empolys what are known as SFS files (Squash File-System). These things can be loaded/unloaded 'on-the-fly' by the use of a special script which has been part of the standard Puppy build-process for well over a decade.

    The simple solution was to build a wee SFS package which would 'load' libffmpeg and libwidevinecdm to the same locations as the .deb package installs them to.....and since these things CAN be 'loaded/unloaded' on-the-fly, and moved from one place to another, they are also portable.

    So you put the portable-Opera in its desired location. You 'load' the Opera-extras.sfs package. You fire the browser up, go to NetFlix/Spotify/Hulu/Amazon Prime/whatever, annnd.....

    .....everything just 'works'. Issue solved, and the 'portable' package remains 'portable', even if it IS now ever so slightly 'clunky' in nature.

    Sorted!

    Mike. 😁

  • @l33t4opera I confirm that widevine is fixed in Opera 67.0.3575.115 (working on Ubuntu 18.04 LTS) but in version downloaded from website as deb package (not through snap - opera installed with snap do not play spotify web)