Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

In order to introduce new security features and enhance your experience with Opera Forums we had to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button.
Apologies for any inconvenience caused.

I can't open new window instead of new tab. Where are advanced settings?

  • Firefox irritates me since it does not switch focus to new opening window.
    Well, I have installed last opera v 22.
    I can't find advanced settings, where I hope I can set opening new windows
    instead of new tab.
    I marked checkbox "Show advanced settings".
    But where they are?
    They is only "settings" in menu.
    No choice to select any other settings in menu.
    No popup menu when I focus mouse on the "settings" line in main menu.
    Maybe it was eliminated in new version,
    because I googled pictures where advanced settings existed before.

  • Hi @ns0001, you can remap the default keybindings for "OpenWindow": ["Ctrl+N"], and "AddBlankTab": ["Ctrl+T"], just follow the steps mentioned here.

  • Thanks, I've found preference file, but there are no words "OpenWindow" or "window" ...

  • You can add it. Just keep the proper hierarchy: Keybindings -> Basic -> OpenWindow, and don't forget about commas. If there's an error, Preferences will be renamed to Preferences.bad.

  • Don't know what your problem is. If I click the Opera menu top right the first two options are "New tab" and "New Window".

    If I press ctrl-T I get a new tab, if I press ctrl-N I get a new Window.

    If I ctrl-click a link it opens in a new tab, if I shift-click a link it opens in a new Window.

    What more do you want??

  • He wants the old setting to have links automatically open in new windows. He may want to post that in the Suggestion Box.

  • My problem is that after opening new window the focus is still on old window,
    not on new window.

  • You can add it. Just keep the proper hierarchy: Keybindings -> Basic -> OpenWindow, and don't forget about commas. If there's an error, Preferences will be renamed to Preferences.bad.

    I added the line "OpenWindow": true,
    after "browser": {

    No results

  • Hi @ns001, close the Opera, go to the Opera's profile directory (you can find the path in O-Menu->About Opera->Paths->Profile), open the "Preferences" file in your text editor, and make sure that the first 10 lines will be exactly the same as below:

    {
       "Keybindings": {
          "Basic": {
             "AddBlankTab": [ "Ctrl+N" ],
             "OpenWindow": [ "Ctrl+T" ]
          },
          "Settings": {
             "AdvancedEnabled": true
          }
       },
    

    Save the changes, close the file, and reopen the Opera.

Log in to reply