Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I think it was 2 days ago, browser wouldn't open. Worked fine the night before. Get the hourglass showing up for 2 seconds, then nothing. Tried everything I can think of-restart computer, used CCleaner which was not able to force Opera to close, uninstall/reinstall several versions at least 5 times now over the past 2 days, paused Zone Alarm firewall, nothing. When I go into Task Manager to end process, it won't end the 2 exe ones on there. Windows 7, as stated ZoneAlarm firewall, Avira AV-which I haven't thought if that might be the issue, I've noticed that being rather spammy. Also, I just remembered about 2 months ago, I had this same problem with Firefox. Any ideas, because I really dislike using Chrome?

  • @Stinkerbell Did you try with a clean profile?

  • @Stinkerbell said in Browser won't open:

    When I go into Task Manager to end process, it won't end the 2 exe ones

    Are those automatically there afgter you restart the computer or do you just mean after you try to open Opera?

  • @leocg Clean profile? Sorry not sure exactly what you mean. I didn't have a profile with Opera, but I did create one to try to save my bookmarks since it wouldn't open and let me export them somewhere. Actually, it did have my email on file, so maybe I did have one. If that's what you meant, how do I go about trying a clean profile?

  • @burnout426 Honestly, I'm not sure. I know restart was one of the first thing I tried. Actually now I just looked, I've uninstalled Opera again, and they're still showing in task manager?? LOL I'm going to go and try a different program to clean everything up. Maybe I'm still having bits leftover? I don't know...this is frustrating though.

  • @Stinkerbell Check the FAQ

  • @leocg Not sure what exactly did it, but I got it up and running 🙂 I used CCleaner and cleaned again,did registry, still showed Opera though it was uninstalled. Did cleaning on Windows tools. Then did a search and found some Opera bits in Program x86 folder. Deleted those. Cleaned registry again. Did restart. Finally stopped showing up on task manager. Did another clean/registry. Then redownloaded it. So, I'm guessing it was something to do with the fragments I had leftover? I don't know...but bookmarks all of it are still there. Lesson learned, back up all that stuff lol. THANK YOU for your help and responses!!!