Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Opera doesn't allow you to set Ecosia as the default search engine.
    I'm just posting this solution to be helpful.

    The following is a workaround.

    1. Set as your default search engine.
    2. Install TamperMonkey extension.
    3. Enter the following script into TamperMonkey.

    This will redirect your search from to automatically. So becomes your default search engine.

    NEVER use scripts from unknown sources.
    This is just a one line command, redirecting you.
    I'm posting the full code here so everyone can review it.


    // ==UserScript==
    // @name         Ecosia Default Search Engine in Opera
    // @namespace
    // @version      0.1
    // @description  Sets Ecosia as default search engine by automatically redirecting you
    //               when you search in DuckDuckGo.
    // @author       Hagbard Hednig
    // @match        http*://**?*q=*
    // ==/UserScript==
    (function() {
  • Sorry, but how do you actually turn this on?
    I installed Tampermonkey and copied the script in and the dashboard says it's enabled, but Tampermonkey says no scripts are running and a search on DuckDuckGo just searches on DuckDuckGo.