Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

chromecast don't work anymore

  • like said , chromecast don't work , can't find the device , the same in chrome browser , i tested other browsers and it work only on vivaldi , it's very strange

  • Dears
    from approximately two weeks my Opera browser (62.0.3331.72) for Win 10 doesn't find my Chromecast.
    On the same time the Google Chrome browser and my Android phone workig with my Chromecast smoothly and properly.

    Do you have any suggestions?

  • Merging topics.

  • When I click Cast..., the “Cast Tab” popup shows Looking for devices... for a couple of seconds and then settles on “No devices found”. Clicking it takes me to a Google KB article that doesn’t help at all; I have two Chromecasts on my network and both show up normally on the Netflix app on my iPad.

    Some additional info:

    • I am running Opera 62.0.3331.72 over Windows 10 v1809 build 17763.615
    • I am absolutely, 100% sure I am connected to the same network as the Chromecast
    • My network does not have AP isolation, and my computer sees it as a private network
    • My antivirus is Bitdefender Free 1.0.15.120
  • I have the same issue. Android devices and Chrome browser cast perfectly but Opera doesn't -- I get "No devices found".

    When I upgraded one of my PCs to Opera v 62.0.3331.72 from an earlier version (not sure which) it connected to Chromecast once the first time, but since then I get "No devices found". (I can ping the Chromecast dongle and the TV to which it is connected from both PCs without any problems.)

  • I have the same issue as well. Works fine on chrome and on my phone. The problem only seems to be in Opera.
    Im running version: 62.0.3331.72 in win 10.

  • Opera Dev has the same issue since 62 version.
    In version 64 the bug still present.
    Upd: Seems developers already know about this problem http://disq.us/p/22xxr3j

  • I have the same problem, when I try cast from opera for windows to my chromecast it says no device found, both devices are in the same network. Also I checked the settings and Chromecast support is enabled. This issue happen every time that Opera browser is updated,...

  • Version 62.0.3331.99 already and the issue still on going... this is so disappointing.

  • Same problem for me. Opera 62.0.3331.99 Linux Mint 19.2 (x86_64; MATE).
    Chromecast is working normally with Chrome at same computer.

  • Same issue here, and this problem has been here for a while now. Would have been nice with some feedback from the developers. The cast feature is one of the things i use all the time with the browser.

  • Developers have fixed it in Opera Dev 64
    http://disq.us/p/23k9ro0

  • @verybatman yeah it work , but "optimize mirroring isn't there"

  • Yeah - the chromecast problem has been fixed in v 63.0.3368.35

Log in to reply