Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • @alobpreis Completely agreed! Jeez, I love Opera, has been my browser of choice for about 4 years even though I still keep a couple others around for practicity, but it's really inconcievable that they haven't fixed the 1-day history offset by now.

  • @hisnibs Still incorrect, with 74.0.3911.139. The times are correct. As I took this screenshot, it is Wednesday the 17th. Screen Shot 2021-02-17 at 12.23.39 PM.png

  • @tlmurray A fix is being tested internally right now. Hopefully everything works out.

  • This should be fixed in this Opera Developer build if you want to test to make sure. Definitely report if it's not fixed.

  • After a quick check, it seems the history alone seems right, I will confirm after a few days to be sure.

    But there's still an issue with the date range. By default the date pickers show you today, but it seems the timezone bug is still there, as today is greyed out. As I'm in UTC -3 (the day change in history used to happen at 9pm), I think this happens because the calendar enables up to 9pm from the previous day.

    Default range, March 1st disabled

    If I go to Februrary and pick from 24th to 26th, it selects 23rd to 25th in the calendar (the dates are right at the top though).

    One day off

    I will also need some days to further test this, as I cannot select March 1st to test the date range filtering.

  • @alobpreis Confirmed. Thanks for checking.

  • @burnout426 Further details:
    Now that it's March 2nd here, I can select March 1st, but selecting from and to March 1st returns no results.
    If after this I click again on the range filter, the selected date on both calendars ir February 27th (!!). On top it still says: "From: 2021-03-01 To:
    2021-03-01" though.

  • @alobpreis Not being able to select today in the time range seems a different issue.

  • @alobpreis The issue with the day on history changing at UTC instead of in local time zone was fixed a while ago and everything seems to be working fine here.

  • @leocg said in HIstory date is incorrect:

    @alobpreis The issue with the day on history changing at UTC instead of in local time zone was fixed a while ago and everything seems to be working fine here.

    Indeed, I'm aware and commented about that some months ago. I was just guessing that maybe the timezone problem is still present in the date filter and is causing this 1 day off issue.

    Update:

    Just confirmed, the issue is with negative timezones. With UTC, UTC+1, etc. everything works fine. I can even select from today to today in the filter. With UTC-1 all issues are back. Selecting "To March 1st", when you reopen the filter popup "Feb 27th" is selected.

    I then moved the computer's date one day forward, the filter lets me select March 2nd, but when I do, March 1st is selected. After clicking on Done, the results belong to March 1st. If I open the filter again, no date appears selected, so I go back to February and I see the 28 is selected on both calendars. However, the dates on top still say "From: 2021-03-02 To: 2021-03-02" but however they still filter from and to March 1st.

    It's weird, like if the timezone bug is occurring twice: once when selecting the date, and again when showing the (supposedly) selected dates when you re-open the date filter, so you actually get a 2 day difference overall. That's also why I was getting February 27th in my previous test.

  • @burnout426
    Experiencing same “History Back Date” issue on my workstation under Opera Version 74.0.3911.203. Read through all the updates and understand issue has been addressed and corrected in Opera Dev Build 76.0.3981.0. My preference would be to wait for Prod release of 76.0.3981.0. Any idea on timing, not urgent, but again would prefer to use Prod version as it’s fully supported. Please advise, thanks in advance.

  • @rcastel I don't follow the release dates too much, but looking at past release dates, I would guess a month and so many days before 76 reaches stable.

  • @rcastel Usually there is a new major stable version every two months. Current stable version is 74, so Opera 76 should be on stable channel about two months after the release of Opera 75 on stable stream.

  • @leocg
    Thanks for the quick reply, I'll set a reminder and will check the History Back Date issue again after Opera 76 has been released and updated on my workstation.

  • @rcastel There's always a chance that Opera 75 will have the fix.

  • @alobpreis said in HIstory date is incorrect:

    Update:

    Just confirmed, the issue is with negative timezones. With UTC, UTC+1, etc. everything works fine. I can even select from today to today in the filter. With UTC-1 all issues are back. Selecting "To March 1st", when you reopen the filter popup "Feb 27th" is selected.

    I then moved the computer's date one day forward, the filter lets me select March 2nd, but when I do, March 1st is selected. After clicking on Done, the results belong to March 1st. If I open the filter again, no date appears selected, so I go back to February and I see the 28 is selected on both calendars. However, the dates on top still say "From: 2021-03-02 To: 2021-03-02" but however they still filter from and to March 1st.

    It's weird, like if the timezone bug is occurring twice: once when selecting the date, and again when showing the (supposedly) selected dates when you re-open the date filter, so you actually get a 2 day difference overall. That's also why I was getting February 27th in my previous test.

    I just tried the latest dev version (76.0.3989.0), and it still has the date range issue I explained here. The history itself, without filtering, looks good. Keep in mind my explanation above was written on March 2nd.

  • @alobpreis It's another issue. Better discuss it in another topic.

  • Would someone please check their History? It would seem, by what I am seeing the last 2 days, that they have this problem fixed. The times appear correct, but haven't checked the date.

    FYI, I have been have other issues with the latest version of Opera (....149). It would start on my W7 machines but not load any web pages. Errors seemed to indicate that there is a problem with the "operaautoupdate.exe" file and the "launch.exe" file for the latest version. I downgraded to version 70......232. Trick is to turn off Opera immediately after the installation is complete, delete the autoupdate file from recent installation, or else it will upgrade to version ...149. Hope you are not having this problem, but I am. Will comfortably stay with version ....232 until they get this resolved.

  • Yes, I confirm the issue is finally fixed for me.
    Running version 75.0.3969.149. Kudos to the Opera team.
    I've been following this thread for a year and a half...

  • Looks fine here as well. Now only the date range issue remains. If there's no separate thread about it I will create it, as suggested by leocg.