Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • From Opera Beta 70 changelog:

    DNA-79195 Wrong date on history

  • @leocg

    Thanks, couldn't find this thread before posting, I wasn't searching for the correct terms. Also just noticed update says the newest version is still 69.0.3686.57. I guess that means we're still waiting on the 70. fix.

  • Well, I just upgraded to 69.0.3686.57 and something was fixed... Now the day changes at midnight, but there's still something wrong: now it's one day off! For example, urls from today, Monday 13th, appear as "Today Sunday 12". I hope version 70 fixes this completely...

    At least now it's a bit easier to know which day each history entry belongs to. 🤣

  • @leocg said in HIstory date is incorrect:

    From Opera Beta 70 changelog:

    DNA-79195 Wrong date on history

    No luck, version 70 still has the same error as version 69. That is, date cutoff is fine, but it says "Today - <yesterday's weekday> <yesterday's date>"
    And for "Yesterday", it's the day before. So the words "today" and "yesterday" are fine, but the dates are all wrong.

  • @alobpreis Seems to happen only if you open the full history page, since the panel doesn't show today and yesterday date.

  • I always use the full page History, as I don't use the lateral bar.
    Anyway, I just tried it and the issue is pretty much the same. With the lateral history I get "today" with no date (fine so far), then "yesterday" with no date, but then comes "Monday 27", instead of "Tuesday 28" (it's Thursday already here).

  • Seems to still be a problem. IDK how it's possible to log a new Bug, but "DNA-79195" does not seem to contain the complete fix for the "one day off" thing.

    Version - 74.0.3911.22

  • I cannot begin to fathom how this severe issue hasn't been solved in years... Only the day cutoff was fixed (e.g. day changing at 9pm), but not the 1 day off.

  • For quite some time, Ctl-H, i.e., history, has been 24 hours off relative to computer time (e.g., Win 10 time), showing the same time of the previous day. It's been reported by probably a number of people, but the error continues. Neither Chrome nor any of the other browsers I have installed -- FF, Edge, Vivaldi -- get it wrong. What's blocking a fix?

  • this problem also happens to me. impossible not to have a solution 😑

  • @alobpreis Completely agreed! Jeez, I love Opera, has been my browser of choice for about 4 years even though I still keep a couple others around for practicity, but it's really inconcievable that they haven't fixed the 1-day history offset by now.

  • @hisnibs Still incorrect, with 74.0.3911.139. The times are correct. As I took this screenshot, it is Wednesday the 17th. Screen Shot 2021-02-17 at 12.23.39 PM.png

  • @tlmurray A fix is being tested internally right now. Hopefully everything works out.

  • This should be fixed in this Opera Developer build if you want to test to make sure. Definitely report if it's not fixed.

  • After a quick check, it seems the history alone seems right, I will confirm after a few days to be sure.

    But there's still an issue with the date range. By default the date pickers show you today, but it seems the timezone bug is still there, as today is greyed out. As I'm in UTC -3 (the day change in history used to happen at 9pm), I think this happens because the calendar enables up to 9pm from the previous day.

    Default range, March 1st disabled

    If I go to Februrary and pick from 24th to 26th, it selects 23rd to 25th in the calendar (the dates are right at the top though).

    One day off

    I will also need some days to further test this, as I cannot select March 1st to test the date range filtering.

  • @alobpreis Confirmed. Thanks for checking.

  • @burnout426 Further details:
    Now that it's March 2nd here, I can select March 1st, but selecting from and to March 1st returns no results.
    If after this I click again on the range filter, the selected date on both calendars ir February 27th (!!). On top it still says: "From: 2021-03-01 To:
    2021-03-01" though.

  • @alobpreis Not being able to select today in the time range seems a different issue.

  • @alobpreis The issue with the day on history changing at UTC instead of in local time zone was fixed a while ago and everything seems to be working fine here.

  • @leocg said in HIstory date is incorrect:

    @alobpreis The issue with the day on history changing at UTC instead of in local time zone was fixed a while ago and everything seems to be working fine here.

    Indeed, I'm aware and commented about that some months ago. I was just guessing that maybe the timezone problem is still present in the date filter and is causing this 1 day off issue.


    Just confirmed, the issue is with negative timezones. With UTC, UTC+1, etc. everything works fine. I can even select from today to today in the filter. With UTC-1 all issues are back. Selecting "To March 1st", when you reopen the filter popup "Feb 27th" is selected.

    I then moved the computer's date one day forward, the filter lets me select March 2nd, but when I do, March 1st is selected. After clicking on Done, the results belong to March 1st. If I open the filter again, no date appears selected, so I go back to February and I see the 28 is selected on both calendars. However, the dates on top still say "From: 2021-03-02 To: 2021-03-02" but however they still filter from and to March 1st.

    It's weird, like if the timezone bug is occurring twice: once when selecting the date, and again when showing the (supposedly) selected dates when you re-open the date filter, so you actually get a 2 day difference overall. That's also why I was getting February 27th in my previous test.