Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Always on top?

  • Out of nowhere, I suddenly find that Opera remains on top no matter what program I open. This just started, and is very annoying. I now have to minimize the browser to see the window beneath it. How did this happen, and how do I fix it?

  • @tjm Check if you didn't enabled some setting in your OS that is doing it.

  • @tjm

    On my subnotebook (screen resolution: 1024x600) it happens with some Opera versions (*) that if Opera is the active window, I can no longer bring other applications to the foreground if the Opera window is maximized.

    I solved this problem by first unmaximizing the Opera window and then reducing its size so that I could click on a window beneath it. Even if I maximized the Opera window again afterwards, this problem did not occur any more.

    (*) Other Chromium-based web browsers like Vivaldi also show this behavior on my device.

  • @yanta Doing this doesn't work. I click on the underlying window and Opera is still on top. I am on Wndows 10, and I have changed no settings, at least not intentionally, in either the browser or Windows.

  • After looking for a setting and being unsuccessful in finding one, I reset the browser to default. That fixed the problem and also screwed up my passwords for this forum and other social media, like Facebook. Rather than go through and reset all my passwords, I am just dumping this for Chrome. Thanks for your attempts at assistance.

Log in to reply