Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Where are settings for default programs? Like .magnet, .torrent?

  • I cannot find this anywhere. When I click on these files nothing happens. Yet in other browsers the proper program is launched. What gives?

  • @rh99 If there is a program associated to the file extension, then it should be launched when you click on those files.

  • @leocg Yeah no kidding. Unfortunately in life things often happen that shouldn't. Like clicking on a magnet file in Opera and see nothing happen after it launches the torrent program fine in Firefox.

  • @rh99 Right, but there are programs associated to those files extensions?

  • @leocg You would think so but there is no "magnet" in Control Panel, Default Programs.

  • Some Bittorrent clients handle the associations for the file types and protocols themselves right in their settings. Some do that without even adding the proper registry settings which causes the file types and protocols not to show up in Default Programs in Windows. It just depends. What client are you using? Chromium-based browsers don't do any workarounds for finding handlers. Things must be set up right in the system for things to work.

  • @burnout426 Ah right. That would explain it. I'm using Deluge and BitLord. I've check the settings. I moved the program from C to D drive - that might have messed things up. I try to keep all my programs off of C so when I reinstall the OS occasionally I don't have to reinstall them. Of course that only works well with portable programs but more and more are offering that option thankfully.

  • @rh99 I see. Where you able to sort it out though via their settings?

  • @burnout426 Nope. Hence my reason for posting here. I always look for file associations first. Now I just open the torrent program and load it manually. Seems to work. Utorrent was so effortless but it just takes up so much resources with their add-on ieutorrent.exe program (think that's what it was). Used up 50% of my CPU!

  • Looking at Deluge, I see that there's an option to associate magnent URLS and torrent files in the installer. Once installed, under "Edit -> Preferences -> Other", there's an option to associate magnent URLs again if you want.

    After installation, I see the torrent file type is available in Default Apps in Windows 10 (under "choose default apps by file type"). Magnet isn't shown under "choose default apps by protocol", but if I run start "Test" "magnet://test" in a command prompt, Deluge opens as expected.

    So, you might just need to run the installer again to fix things.

    I didn't take a look at Bitlord. I see lots of people mentioning it contains malware. I wait till later to install it under a safe environment.

  • test.html:

    <a href="magnet://test">test</a>
    

    I also clicked on that link in both Opera and Chrome and they ask me if I want to open it up in Deluge.

  • Also, after telling Opera not to ask me what I want to do every time I click on a magnet link, the following is stored in Opera's "Preferences" file.

    protocol_hander {
       "excluded_schemes" : {
          "magnet" : false
       }
    }
    

    Then, magnet links open in Deluge without any prompts.

  • @burnout426 I suspect the problem may be that its not in its expected place:
    (C:\Program Files\Deluge
    Instead its on D drive. I do have this problem occasionally with Win7 that I never had with XP. I tried adding a shortcut to C but it didn't work.

  • On 64-bit Win 7, it should be installed to "C:\Program Files (x86)\Deluge" by default as it's 32-bit. ("C:\Program Files\Deluge" if you have 32-bit Win 7).

    If you install Deluge to a different spot (on a different drive for example), the installer should handle the path correctly when registering the magnet protocol and torrent file type handling. But, if it doesn't, you can check HKEY_CLASSES_ROOT\Magnet\shell\open\command, HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Magnet\shell\open\command, and HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Deluge\shell\open\command in the registry to make sure they have the correct paths to deluge.exe. If not, you can fix the paths and then things should work in Opera.

  • @burnout426 Thank you. That is very good advice. When in doubt, check the registry!

Log in to reply