Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Black screen instead of browser after update

  • @dario2910os i have a solution (worked for me) try to launch opera and just click on your random speed dials hopefully after some time it will open then turn off "Hardware Acceleration" in settings menu. It will solve this problem (mine just did and its working fine now)

  • I have the exact same problem. Opera worked just fine in the morning, but after I updated it, I only get a black screen when I try to launch it. Icons are somehow clickable although I can't see them (I was able to close the window by clicking the cross). I'm thinking the problem might be with hardware acceleration (which I have ticked), because I had a similar problem a couple of years ago with Opera crashing the video card driver (or whatever it is called, sorry, I'm not tech savvy). The issue that time was fixed when a browser update came out eventually. My PC is old, and I can't exactly have it updgraded now or tweak with Windows, but since I'm posting this using Firefox, it goes to show that the problem is with Opera and not with something else.

  • Same. 4/5 times browser just opens a black screen, though all tabs are active in task manager and I can see their names pointing at the top of the window, where all tabs actually are. But in 20% of attempts opening the browser, it does open ok.

  • Turning off hardware acceleration helped. It is kind of sluggish. After opening Speed Dial it takes a second or two to show icons. All else works fine.

  • @dario2910os we made some changes to default wallpapers (SVGs) and suspect they could be causing this issue. Could you try changing wallpaper to not default one and see if you can start Opera after enabling hardware acceleration?

  • @mgeffro I turned on Hardware Acceleration and changed wallpaper. Now I'm getting black screen again, both in standard and Incognito mode.

  • Thanks. We already discovered that problem is caused by newer version of d3dcompiler_47.dll library (version 10.0.18362.1). You could copy this library from some old installation to not have to disable hardware acceleration.

  • @dario2910os we released today update 60.0.3255.84 with fix for this issue.

  • Last update fixed the issue. Thanks.

  • Recently, That's the same issue with my Opera on the web.

Log in to reply