Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Flashplayer not working

  • I get similar errors, which can be ignored I assume, but flash is working for me...

    [5715:5732:0519/112902.167735:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.DBus.Properties.Get: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
    [5715:5732:0519/112902.168221:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.GetDisplayDevice: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
    [5715:5732:0519/112902.168626:ERROR:object_proxy.cc(621)] Failed to call method: org.freedesktop.UPower.EnumerateDevices: object_path= /org/freedesktop/UPower: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.UPower was not provided by any .service files
    [5715:5715:0519/112904.851415:ERROR:CONSOLE(0)] "Unchecked runtime.lastError while running operaTouchPrivate.getLocalName: Cannot obtain local name
        at chrome-extension://ebongfbmlegepmkkdjlnlmdcmckedlal/touch_communication.js:248:35", source: chrome-extension://ebongfbmlegepmkkdjlnlmdcmckedlal/page.html (0)
    [5715:5715:0519/112905.335769:ERROR:CONSOLE(0)] "Uncaught (in promise) #<Object>", source: chrome-extension://obhaigpnhcioanniiaepcgkdilopflbb/background_worker.html (0)
    [5715:5715:0519/112939.782508:ERROR:opera_notification_delegate.cc(60)] Not implemented reached in virtual void opera::OperaNotificationDelegate::Merge(std::unique_ptr<OperaNotificationDelegate>)
    [WARNING:flash/platform/pepper/pep_module.cpp(63)] SANDBOXED
    

    That last line came up when I ran the flash verification on adobe's page.

  • @jimunderscorep said in Flashplayer not working:

    That last line came up when I ran the flash verification on adobe's page.

    I see this line in Chromium. I removed and installed Chromium again. Flash works, but is not enabled there. I need to re-enable it on Adobe's page every time I start browser.
    I can't understand, what block it to run in Opera. May be something wrong with my user profile?
    P.S. I made a backup of my .config/opera dir, and then I start Opera. It created the new profile, and flash works fine there. How can I find, what's wrong in my profile?

  • I think the problem is solved. I cleared browsing data by selecting content check box. Now flash is working in Opera.

  • Hi @pindos, it's nice to hear that it's solved for you, so it seem to be some issue with the cache/content data, but for some users, I couldn't reproduce it myself.

    If the problem will be back in future, you can check if it's not a conflict of several versions installed, and recognized by the Opera (or Chromium) - more details here.

  • @l33t4opera , hi! It seems to me that the problem is in synchronization of Opera with my account. I remembered that I had something like this nearly a year ago. I changed my laptop. The previous synced data was made in 32 bit version of Opera, and the new one was in 64 bit. At that time there were similar problems with flash, as far as I remember. But I thought that they were gone since that time. I'll try to watch for this thing.
    The interesting thing that this problem appeared in Chromium too. I don't have an account for that browser. And I use it very rarely.

  • @pindos I see, so rather it's not sync, which causes the issue in the Opera. Perhaps there were similar changes in the Preferences file in both browsers, that triggered the issue, and as you wrote above, that clearing the cache/browser data solves it, it might be that the old data for the plug-in are removed properly now. If you make backups of your Opera's profile folder, you can compare one of the old files, with the current one.

    On the other hand, as some of people wrote it the link I provided above, the problem may return, when the other version of the plug-in enables itself again. If that occurs in your case, you can try to avoid it in the future by leaving the only path to the proper (recent) version of the plug-in in the pepper_flash_config.json file for Opera (you need to re-edit it after every update), and by providing the strict path in the command line switch (as mentioned above for Chromium) - you can also add another switch with version number, so it will look as follows: /path/to/chromium --ppapi-flash-path="/usr/lib/adobe-flashplugin/libpepflashplayer.so" --ppapi-flash-version="32.0.0.192".

  • @l33t4opera

    On Windows, it works also even without PlugIn info: --ppapi-flash-version=32.0.0.192

  • @l33t4opera , thank's for your detailed reply! 🙂 I'll watch for Opera's behavior.

  • @zalex108 , Flash works fine even without any special keys in Windows. But me discuss about Opera for Linux in this thread.

  • @pindos

    I use Opera as StandAlone, and have to add Flash switch too.

    When the Switch is too long the PlugIn info is cutted, but Flash works without all that switch part.

    Just said in case you were using other switches too.

  • You have to follow this steps to make it work.
    Test it at the link bellow:
    https://helpx.adobe.com/flash-player.html

  • Opera 60.0.3255.151 and Flash Player 32.0.0.192 in Kubuntu 19.04 (all 64-bits) - still does not work, although some pages are saying, that I have Flash Player 32.0.0 installed.

    AAA.png

  • a) Use a page that has a flash based element on it, like adobe's page here, and not some page that relies on js to determine if flash is installed
    https://get.adobe.com/flashplayer/about/

    b) On a page where flash "does not work", make sure the page does use flash and not some html5 tech that is partially supported or unsupported by opera.

  • @jimunderscorep Flash doesn't work, that's the short message.

  • It works for me. Proof on the requested page

    2019-06-08-070408_1280x1024_scrot.png

    However, I prefer to keep it disabled for all sites and explicitly allow it on the ones I want.
    Are you using the snap version of opera by any chance!

  • Well, it didn't work for me, but I've read in other topic in this forum

    I just ran Opera -no-sandbox

    Flash player works great.

    Still no widevine yet... So I cannot play spotify or netflix in Opera Linux.

    Flash player now works perfectly on Opera. What't the reason for it? What "-no-sandbox" option really does?

  • I updated today Opera, and the result is:7d70930d-b0a0-47e4-95d4-8f7baea3a403-image.png
    But still can not play all youtube videos neither netflix or spotify...
    System:
    14cb47a6-0af4-4eb1-8f56-73b47c10e2f9-image.png
    Opera:
    f3d8cc14-6134-4439-b467-536f2bf7ac7d-image.png

  • @sgfdhsg And what Flash has to do with it?

  • @leocg 32.0.0.192

  • @sgfdhsg I didn't ask for the Flash version.

Log in to reply