Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Updated Opera and VPN still doesn't work

  • (1) VPN quit working about 24 hours ago, weeks after the first autoupdate to the "new look" version 60, after a subsequent autoupdate. For a while, VPN simply wouldn't work at all; I couldn't even turn it on. Over time it changed to where I can turn it on and it gives the impression that VPN is working, but if I try to connect to any website, nothing happens for 15-20 seconds and then the VPN connection "disappears" again. if I re-enable VPN and try again, the same behavior results. Is this because VPN is broken for everyone? Or is it just for me?

    (2) Can I fix this by reverting to Opera version 58?

    (3) At some point in my wandering around trying to understand what's going on, I came upon a window that offered three different locations for where I would appear to be; Europe, Asia, or America. Now that window seems to have disappeared! Can anyone please tell me how to find it again?

    I'm running 64-bit Windows 7. Thanks very much.....

  • @unionjack Same, with at least one site. I have to turn mine off to even browse properly.

    Also as an update to my previous statements, the newest download in the link provided didn't solve the problem for me. I'm fully updated, currently.

  • @jtouser Same here mate, Obviously still not totally fixed. Keeps gettibng this TUNNEL CONNECTION FAILED, Then hust sits no matter how many times I refresh.

  • I tried Americas, Europe and Asia - none of them work. From Western Australia.

    Is it me or is this a general situation?

  • Hi,
    My opera VPN is having multiple issues of slowness and interruptions which I'm facing from the last 2 days. I have updated to the lastest update. But,the issue still persists.VPN gets disconnected often.

  • I've just updated to 60.0.3255.59 (Linux Mint 19.1) and VPN is working again.

  • If VPN is enabled it can not open any sites, it is saying that - vpn is temporary unavailable. Is it true? or its just my systems problem?

  • @celeritasworld can't connect either but fortunately opera keeps the user informed of any issues.

  • Just now, try to update to version 60.0.3255.59 the VPN service is back.

  • @leocg I've downloaded the versions listed, NONE of them work or resolve the VPN is connecting issue, so if you can direct me to this miracle solution I would be very grateful.

  • I have been having the same problem, happening on multiple devices on different ISPs. I am in the UK and I wondered if Opera's VPN is being blocked?

  • I have the same problem.

  • I have the newest version for windows still not working


    Make sure you have one of those builds installed as they were released to fix the VPN issue.

  • yeah, been there done that
    Still don't have the VPN working

    whatever the problem was hasn't been fixed.... or the fix has made a new problem

  • @leocg said in Updated Opera and VPN still doesn't work:

    Make sure you have one of those builds installed as they were released to fix the VPN issue.

    I updated with the menu option - didn't fix the problem.
    I updated by downloading "Opera Stable for Windows" using the link you provided - didn't fix the problem.
    VPN was working fine before two days ago.
    As you can see, I'm up to date.

    So far, just today alone (a full day after updating), it hasn't cut out or denied access, but that wasn't the case yesterday by any means. So I am guessing there are still a number of glitches somewhere causing it to cut out. Will continue to update everyone with my personal experience.

  • @jtouser
    As you'll see from my snapshot - I'm well stuck, with zero Opera VPN. I'm in UK.
    This post from Windows10 system.


  • @winston1984smith OK; problem solved, by stringing together these announcements from various places:

    "Opera 58.0.3135.132 and 60.0.3255.59 Stable update 
    Grzegorz Miazga Apr 21, 2019 (20) ( 

    Today we have a small update containing a new HTTP certificate pin for our VPN service. The
    update pin is available in builds 58.0.3135.132 and 60.0.3255.59."
    "Download the latest version from 3135-132-and-60-0-3255-59-stable-update/"
    "3255.59 is the version with the fix."

    And that worked; now VPN is back on 4/21/2019 (after wasting a lot of my time...) Why not put this at the top of the Forum page, to get everyone's attention?

    Also; how to change the VPN location? L-click on the blue/orange [VPN] button at the top lefthand corner of the window. If VPN isn't working with the current choice, pick another -- that's what I had to do.

  • @unionjack

    See my post above; that might fix it for you! Good luck...... 🙂

  • @winston1984smith As many in the thread have pointed out (myself included initially), the stable version doesn't work for everyone.
    In fact, this evening is the first full hour so far where I haven't had any issues, and that came 24 hours after I updated the browser twice, both times to the latest version you, and a moderator, stated.

    My only guess is that it's taking time for the certificates to fully update, depending on location of the host browser (end-user).