Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Short lag after idle time

  • So here’s the deal. I’m not sure when exactly it started happening, but it was months ago. Every time I’m reading something and don’t move the mouse or anything for a while, there seems to be a short lag or twitch after this idle time, which I’ve counted to be around 15 seconds. If it’s less than 10 or so, it works normally, but after the longer time, it sort of freezes for a split second.
    I started noticing it because of scrolling; installed Smooth scroll add-on, but while it makes things nicer, it doesn’t have any effect on this thing. Then I realized it’s not connected exclusively with scrolling, but really with everything. E.g. when I want to highlight a part of a text, there is the same split-second lag. It might seem king of wtf meh, but it’s very annoying, and I’d like to resolve it if possible at all.
    In short, Opera sort of hibernates after some 15 seconds, making scrolling and other things frustrating.
    I’ve tried disabling add-ons, my computer is of high performance etc., let’s skip all this.

    Thank you for any advice.

  • Seriously, nobody?

  • Well thanks heaps then!

  • @jamillos i don't think n e one is have 'n a problem esp with the mouse like you say 'n in opera..

    does those problems happen in other browsers.. and or in your windows too..

    @jamillos said in Short lag after idle time:

    Opera sort of hibernates after some 15 seconds, making scrolling and other things frustrating.

    what other thngs.. can ya explain a bit more..

  • Do you see eg some disk activity after 15 seconds? It could be possible that part of Opera (or some other program) kicks in after 15 seconds on inactivity and starts some kind of background operation and your computer waits for some hardware or something.

  • @nvmjustagirl Nope, and the weird thing is this doesn’t happen on any other laptops with different (older) Windows, so this has to be a Win 10 thing. Mozilla runs perfectly in this regard.
    Well the scrolling is frustrating cause it twitches once, the lines skip a bit, you know. You can also see it when you try highlighting a text, like I said above, or really do anything – you just can notice the initial delay after those 10–15 seconds; after that, everything is alright again... until you stop doing anything for the same period.

  • @donq I haven’t noticed anything like that.

  • @jamillos i think ya should try the latest opera except i would do the offline version.. Install it as a portable..

    test to see if ya still have problems..

    i don't think mouse is bad... but heres a couple thingys to try..

    go to Opera Settings > Advanced Settings > Browser - Scroll down under system, check box (Use Hardware Acceleration when available)

    If Opera is running with Hardware acceleration activated, see if disabling could help the issue to go away..

    you said this - (this doesn’t happen on any other laptops with different (older) Windows)

    i'm assumming your use 'n the same mouse to test the other laptops.. ummm opera does not change mouse settings.. but that win 10 update might be affecting Opera sum how..

    try this in mouse settings = mouse acceleration

    go to control panel - mouse - click the Pointer Options tab - uncheck box called - Enhanced pointer percision and or check the box - hit Apply - then ok

  • Wow, so here’s the thing: disabling hw acceleration in settlings did help. However, it’s not as smooth overall, whether the scrolling or e.g. a 1080p60 youtube video I’ve tried. So I’ve switched it back on, and I think we can forget it, cause I can sacrifice a little discomfort of this sort over a crappy video. Hey, maybe they’ll fix it with some future versions (whether Opera or Windows).

    Anyway, thanks for the help!

  • @jamillos you're welcome..

    one last thing you can try with hw acceleration on is this..

    type this in opera 's address bar

    opera://flags/#ignore-gpu-blacklist

    and Enable - Override software rendering list

Log in to reply