Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Site not working anymore but works on Slimjet

  • http://harvesthonors.org/harvest-honors.html

    this has stop working. Used to work. Still works fine in Slimjet browser.

    Flash player and opera are up to date.

    What can I do? (besides trashing Opera)

  • And 'has stop working' means....?

    Did you try to add the site to the allowed list for Flash?

  • In Opera, goto the URL opera://settings/content/flash, make sure "Allow sites to run Flash" is enabled, make sure "Ask first" is enabled, and make sure there's an entry for http://harvesthonors.org:80 in the "Allow" list.

    Then, it should just work as long as you have Flash installed for Opera. If not, goto https://get.adobe.com/flashplayer/ in Opera to download and install it.

    If things still don't work, when you're on the http://harvesthonors.org/harvest-honors.html page, click the badge at the left of the address field and click on "Cookies". Then, delete all the cookies shown and reload the page to try again. When you click on the badge, you should also see that Flash is set to "Allow".

    If that doesn't work, clear your cache and try again. Goto the URL opera://settings/clearBrowserData, switch to "Advanced", set the "Time Range" to "All Time", uncheck everything but "Cached images and files" and click "Clear data".

    If it still doesn't work and you have Opera's adblocker turned on, turn it off. Or, you can turn the adblocker off for just the site by going to the URL opera://settings/adBlockerExceptions and adding an entry for [*.]harvesthonors.org.

    If none of that works, do you use Opera Sync?

  • of course. I've done it all.
    thx.

  • And what exactly the problem is? Since support to Flash is being dropped by Chromium, allowing Flash on sites is becoming more difficult.

  • @gpc1965 Download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation", uncheck "import data from default browser" and install. Test in that Opera. Do not enable Opera Sync in it and do not install any extensions in it.

    Does it work there at least?