Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Hello everyone.

    I have 16 gigs of ram and have a pretty tab-centric workflow. I am getting a lot of "out of memory" crashes lately and I was wondering if I could give Opera more ram to use.

    I am not looking for suggestions like "disable addons", "get a tab suspender" or "that's a stupid workflow". I know them and applied them or am simply not interested. I have memory to spare and want to put it to use.

    Many thanks in advance!


  • @yaguznal said in How to allow Opera more memory:

    I am not looking for suggestions like "disable addons"

    Do you mean you have tried to disable all your addons and this did not help? Otherwise you should try - running out of memory is certainly not widespread problem in Opera and thereby addons (extensions) can be one of causes for your problems. This is always part of basic troubleshooting.

    Then - do you have found some correlation between running out of memory and specific sites? If yes, then what kind of sites cause memory problems? If for example video heavy sites, then this may be problem with your video drivers (or rather Opera and graphic system interaction) - disable hardware acceleration, upgrade drivers and so on.

    Then - are you using some third-party antivirus or other security software? Those are usually hooked into any other processes at very low level and sometimes they do not play along with other programs, causing mysterious problems. If you have any such kind of software, just disable it temporarily and watch Opera behavior.

  • Opera's already set to use all the memory per process the OS will give each process. That's more for 64-bit Opera of course. There's no configuration except for something you might find in

    Sounds like a memory leak issue. Hit Shift + ESC to open Opera's task manager and monitor that. Maybe you can catch what's using all the RAM before Opera crashes. It might be the GPU where disabling hardware acceleration in opera://settings/system might help.

    You might want to test in Opera Beta and Opera Developer. If they don't have the problem, perhaps it was a bug in Opera that's been fixed (where the fix will reach stable eventually).

  • @yaguznal i dunno if this will help..

    Go to opera://flags/

    Enable this flag called - (Memory coordinator) it suppost to give the browser control of manage 'n memory instead of the operating system..

    then later on perhaps this one..
    try this Flag called - (Strict site isolation) *uses more ram probaly..

    it is meant to make browser more stable and secure.. By separate 'n - every tab - plug 'n - extension - into its own process.. *may use more ram..