Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Opera stuttering and occasionally freezes while playing YouTube videos

  • @epop11rt3 those fps will be good esp with a fast internet connection..

    you said this - (6.00GB Single-Channel DDR3 @ 798MHz)

    this is where ya got a bit of a bottle neck perhaps..

    even tho high performance did better for ya.. your video card memory is probably about - 335 Mhz base speed - 497Mhz - upto 800 Mhz..

    and thats the speed No matter which power plan ya use.. not much ya can do about that..

    so just remember that your graphic settings can always be set back to the AMD default easily if do decide to adjust slightly..

    could ya check this to make sure this is not on..

    Assuming Windows 10 1803:

    Start - Settings - Gaming - Game bar

    Set "Record game clips, screenshots, and broadcast using Game bar" to Off

  • @epop11rt3 when ya get time lets double check to make sure that (Hardware acceleration) is Enabled and to make sure your GPU is not black listed..

    we wanna make sure the words (Hardware accelerated) appear next to most of the items (like in the below Example)..

    Note - If you see that the (Use hardware acceleration when available) option is already enabled but your GPU setting shows that acceleration is unavailable = Your Gpu may be black listed..

    So all ya need to do is - in the address bar open opera://gpu

    Look @ the 1st heading called - (Graphics Feature Status) - under that heading ya will see items like these..

    Example

    (Graphics Feature Status)

    Canvas: Hardware accelerated
    Flash: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Flash Stage3D Baseline profile: Hardware accelerated
    Compositing: Hardware accelerated
    Multiple Raster Threads: Force enabled
    Native GpuMemoryBuffers: Hardware accelerated
    Rasterization: Hardware accelerated
    Surface Synchronization: Enabled
    Video Decode: Hardware accelerated
    WebGL: Hardware accelerated
    WebGL2: Hardware accelerated

    take a snapshot of (Graphics Feature Status and the items) is all ya need and post it for us to see..

    then check down @ the bottom of that same page also for the heading called - (Log Messages) to see if n e errors or messages appear/show up..

    Note - before take 'n the screen shot make sure that (Use Hardware Acceleration when available) is Enabled in the Opera Settings..

    Note - Unfortunately, hardware acceleration can't help with buffering (this has to do with your internet connection) does the freeze happen right after try 'n to buffer..

  • @nvmjustagirl It's really not much of an issue I have with buffering, but in addition to when I am watching a video, these occasional freezes also happen seconds after I start playing a YouTube video.

  • @epop11rt3 do you have Win10 1803, 1809.. and the version..

    i dunno if ya checked if ya had the Win10 1803 CryptSvc problem.. it causes freeze beside other stuff..

    ya should move on up to 1809 if possible

    have ya updated that old version 58.0.3135.68 to the new one..

    did ya ever disable all extension then try youtube..

    ya never posted a snapshot from the above post.. about (Graphics Feature Status)..

    ya may need to make a new profile..

    before ya check and do all that

    do this..

    turn the service on called Superfetch or try it disabled.. try both ways on or off

    go to control panel - sound - playback tab - right click speakers - click properties - Advance tab - Select the sample rate in the drop down menu and set it to..

    16 bit, 44100 Hz or this one - 24 bit, 96000 Hz

    Right-click on your Opera desktop icon and select Properties

    Go to Shortcut tab
    Now, in the Target field, add the following code at the end of the link --disk-cache-size=1073741824

    that disk cache size = 1GB

    Eample..
    "C:\Program Files (x86)\Opera\launcher.exe" -–disk-cache-size=1073741824 (I may have this wrong) lol

    ummm.. one thing i've noticed that seems to be broken in most of the window 's uodates is this.. (ya will be freeze free !)

    and so ya will notice it the most.. we will do this in the regular 'ol Balanced power plan.. but i would do all power plans..

    Go to start - Power Options - Balanced power plan - click Change plan settings - click Change advance power settings - now while in Advanced settings scroll down to PCI Express click to open - then click open (Link State Power Management) - then click (Plugged in) in the drop down menu box click the option Off - Also do the same for the one called - (On battery) click the option off in the drop down menu - click Apply then Ok it..

    go to utube except.. Restore to the Old Version of Youtube.. then Test with only 1 tab with 24fps or 30 fps..

    Now Com 'on & give us sum Feedback ? ! lol

  • @nvmjustagirl Very sorry I didn't post a snapshot for the above post yet. I will make sure to post one ASAP. I am not sure where I would find Superfetch. I have the Win 10 version 1809 installed on my computer, and as for updating my Opera browser, I have yet to check if it needs updated because I haven't used it in a while. I still need to test YouTube with all extensions disabled. When I do, I'll make sure to post a screenshot of Graphics Feature Status. I am hesitant to try adjusting the sound settings, because I am not having any audio issues.

  • @nvmjustagirl here is the screenshot you requestedAnnotation 2019-03-26 172031.JPG a few other things I want to note:

    1. I don't use my Windows 10 laptop for gaming purposes.
    2. I have the most current version of Opera.
    3. I tried disabling all extensions on my browser except for my ad-blocker, but will run further tests later, re-enabling my extensions one by one. I only had a single tab open (YouTube), and video playback seemed to be smooth, but got at least one or two hiccups.
    4. I just realized that I wanted to give you the info about the Log Messages, so here is the info for you I have copied onto a Word document:

    Log Messages
    GpuProcessHostUIShim:
    [4948:12228:0326/165102.949:WARNING:angle_platform_impl.cc(52)] : compileToBinary(232): C:\fakepath(65,8-58): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them C:\fakepath(73,9-43): warning X3571: pow(f, e) will not work for negative f, use abs(f) or conditionally handle negative values if you expect them
    GpuProcessHostUIShim:

  • @leocg this is for leocg only.. epop11rt3 Logs show same thing as this web page - scroll down over half way or so - to see the look alike log messages..

    looks like an old chomium bug found here - https://bugs.chromium.org/p/chromium/issues/detail?id=764036

    to epop11rt3 - seems like ya don't update n e thing often..

    the audio thingy was not about if ya had issues but was for sumthing else n e ways it does not matter..

    am glad ya posted screen shot.. because this is the main issue..

    in your logs looks like the shader is hitting a bug in one your GPU drivers...

    have you updated your amd graphic card.. looks like amd website https://www.amd.com/en/support has a couple updates for your Windows 10 - 64-Bit AMD video card.. one of them is - 1/21/2019 - the other is - 3/20/2019 -..

    ok so 1 - the log also shows a bug that was in (Chrome from around 2017).. I know Opera Forum did a little work to their website lately and so when you uploaded your screen shot sumthing may have happened.. but

    how old is that chrome version ya got.. lol

    2 - back to the Chromium bug (Shader compile error).. your logs shows this bug was reported here - https://bugs.chromium.org/p/chromium/issues/detail?id=764036.. and also here https://github.com/Strilanc/Quirk/issues/378..

    i dunno if this was fixed.. and this is way over my head..

    so maybe leocg can shed sum light on this Chromium bug..

    Help leocg.. please !..

    Note - To epop11rt3 - answer and do what ever leocg says please..

  • Sorry but there isn't much that I can do.

  • @epop11rt3 i think ya said ya wanted to turn on a couple more in your screenshot of (Graphics Feature Status) so here is a couple.. if ya need more post which ones..

    type this in opera 's address bar

    opera://flags/#ignore-gpu-blacklist

    and Enable - Override software rendering list

    Enable 'n this flag will change - Hardware Protected Video Decode: Unavailable

    to = Hardware accelerated..

    also that same flag will change - Rasterization: Unavailable

    to = Hardware accelerated..

    also get chrome updated And your gaphic drivers..

  • @nvmjustagirl said in Opera stuttering and occasionally freezes while playing YouTube videos:

    @epop11rt3 i think ya said ya wanted to turn on a couple more in your screenshot of (Graphics Feature Status) so here is a couple.. if ya need more post which ones..

    type this in opera 's address bar

    opera://flags/#ignore-gpu-blacklist

    and Enable - Override software rendering list

    Enable 'n this flag will change - Hardware Protected Video Decode: Unavailable

    to = Hardware accelerated..

    also that same flag will change - Rasterization: Unavailable

    to = Hardware accelerated..

    also get chrome updated And your gaphic drivers..

    I am pleased to report that I am currently able to run Opera smoothly after updating the browser, and tweaking a few settings. I also have this extension called Speed Up Browsing, which seems to have made an improvement in performance. As of this current post, I currently have several tabs open in Opera (while running this other extension called Tab Suspender, which automatically suspends inactive background tabs after a set period of time) with no performance hits, even while playing YouTube videos in HD