PayPal suddenly not working in Opera 12.17

  • Pretty much as the title.
    All PayPal pages now seem to load and then immediately go to a blank white screen on Opera 12.17.
    Had been working fine for ages when masked as Internet Explorer.
    Tried all other options, but no difference.
    Anyone else seeing this?
    :-(

  • I've just done a quick test and had no problems. Opera was set to identify as Opera.

    Have you tried cleaning cache and cookies?

  • Tried clearing cookies, which made no difference.
    Switching off the content blocker and disabling Adblock made no difference either.
    Good to know it's still working for you though, it does mean it's a problem my end!
    I will investigate further and report back.
    Thanks.
    :-)

  • White page... Where have we seen this before? :)
    64-bit version? Could that be the same issue affecting Outlook.com (solution here)?

  • I'm using the 32 bit version of 12.17, and the "public_domains.dat" is present in my Opera\Defaults folder, which I presume is where it's supposed to be.
    To add to the mystery, I have Opera 12.02 installed on the Windows 98 (!) side of my dual boot machine, and Opera 12.17 also installed on another machine. On both of those the PayPal pages still work perfectly!
    I can see no difference in the site preference settings on any of the three Opera installations, and yet it works on two of them and not on the third!
    :-)

  • Rename your Opera's profile folder and see if it helps.

  • More random attempts to discover the cause of the issue. ;)

    • I assume no add-ons...
    • You could check whether there are any site preferences set to Paypal in override.ini
    • You could try removing opuntrust.dat from your profile (I think the file stores info about previously denied certificates)
  • I tried removing my operaprefs.ini file and allowing Opera to recreate it.
    I got a rather worrying page that told me it was "time to upgrade" (to Opera 21) - no it isn't!
    Despite that, Opera ran completely un-customised, and the PayPal pages worked fine.
    After restoring the original preferences file, I've now tried completely clearing my cache, completely cleared all the PayPal entries from blocked content, cookies, site preferences, and storage.
    Still no joy, the pages still crash to a white screen after loading.
    As far as I can tell, all other sites are working correctly.
    Any other thoughts?
    :-)

  • Ah ha! Found the problem!
    I had set a custom user agent string in the operaprefs page.

    opera:config#UserPrefs|CustomUser-Agent
    (Sorry this rubbish forum doesn't seem to allow you to easily put the link in so it actually works like it did in the old forum.)

    It was "Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0"
    This was to stop my webmail nagging me to upgrade my browser every time I logged in (it's set to mask as Firefox).
    This worked, but seems to have stopped the PayPal pages from working as well, ever though they're set to mask as Internet Explorer! I hadn't done it on the other Opera installations, which is why they still worked.

    Is there any way around this?
    What does setting a custom user agent actually do?
    There seems to be no way of setting it as an option in individual site preferences.
    :-)

  • Well I think I understand it now, the custom user agent option is a global setting which over-rides the normal choice of global settings, which is no good in my case as it stops PayPal from working.
    I need to put in a custom user agent string just for my webmail site.
    Is that possible, perhaps by manually editing the site's entry in override.ini?
    :-)

  • Access the webmail page then press F12 or right-click the site background, select "Edit site preferences" check that the domain where the override will be applied is correct and in one of the latest tabs there's a browser identification setting, it changes the UA-String only for that domain, try it out.

  • Thanks Rafael, but that's what I've already done.
    I've had it set to mask as Firefox for a long time, or the site malfunctions.
    The problem is that it's still telling me to upgrade my browser when I log in (although it does function properly after that) and I assume that's because the Firefox user agent string it's sending is out of date, and the site thinks I'm using an out of date version of Firefox!
    I was hoping to be able to set it to tell the site it's a later version.
    Can you edit the default Firefox and IE spoofing strings anywhere, I can't find them in any of the ini files?
    Are they actually hard coded?
    :-)

  • Can you edit the default Firefox and IE spoofing strings anywhere, I can't find them in any of the ini files?
    I don't know, in the past when users asked for a way to spoof as Chrome no one ever came with that suggestion so it may not be possible...

    How about removing the webmail site prefs (from override.ini, or I don't know, via the UI) and using your previous method of opera:config#UserPrefs|CustomUser-Agent but instead of Fx's use the new Opera UA-String? :)
    E.g. Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.132 Safari/537.36 OPR/21.0.1432.67

  • Thanks again.
    Just tried that, but unfortunately it makes all the PayPal pages go to a white screen again!
    :-(

  • Hey what if you mimic a Identify as Firefox string but creating your own update?

    You could try something like "Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0 Opera/12.17" in opera:config#UserPrefs|CustomUser-Agent.

  • That still messes up PayPal I'm afraid!
    :-)

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.