Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

In order to introduce new security features and enhance your experience with Opera Forums we had to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button.
Apologies for any inconvenience caused.

Link redirected in different languages

  • Hello people.
    I have a trouble, shortly:
    I'm Italian and english speaking. Now I'm in Russia, and several links I need in english or italian language, are redirected in russian version.
    For exammple, last I tried:
    https://www.dell.com/support/home/it/it/itbsdt1/product-support/product/inspiron-15r-n5110/drivers

    (is "dell" page to get drivers and so on)

    when I paste it in OPERA, automatically redirect me in

    https://www.dell.com/support/home/ru/ru/rubsdt1/product-support/product/inspiron-15r-n5110/drivers

    But last one is russian page, and I don't understand cirillic!!! 😞

    That happens with several multi-language sites... now: in settings I put "italian" as preferred language, even for browser and results. I tried also to go to ling with VPN active, and changing different places, but still links me in russian page; I tried with CHROME and FF, and with those other browsers it works good: tI get italian page... how can I fix it in Opera? Opera is my favourite browser by more than 15 years, I don't like to skip to other onejust for this annoying trouble...

    Thank you for your attention, I wish someone would be able to give me a hint!

    Happy 2019!

  • Is Italian or English set as preferred language for web pages?

  • What about Opera setting "Pop-ups and redirects"?

    opera://settings/content/popups

    I myself have never tried this option before.

  • as preferred I have Italian, but also I tryed English: no way.... some links, automatically changes in Russian, when I'm in Russia. In Lituanian whem I'm in Lituania, Polland, so on,,, that's annoying....

  • @yanta in that page, I just see: a switch, setted on off. then "loked": no entries, and "allowed": no entries... I don't see any language option.... 😕

  • Maybe the site is redirecting you based on your IP address?

  • @leocg Yep ok, maybe... but I don't know how to solve this. For sure, something see I am in Russia now, and sends me in russian page: but why just in Opera, not in FF or Chrome? that's the question.... if was working in same way with all browsers ok: I'd be disappointed, but I'd never open this thread! 🙂
    The link I posted is just an example: but with several ones it happens! Every time a site has a multilang menu, I'm redirectet in russia. (here... or german if in germany, so on...), but is not always SO EASY, to shift in english or italian pages. And anyway, everytime I click a link, with Opera I get again in a page in local language. Ho w can I set "something" (in Opera I guess, as just in Opera happens), just to get exactly the link I type, without any redirect?
    Tnk you for your time leocg!

    EDIT: I'm not a OS or PC expert, I'm just a final programmer on mechanic machines gui.... but: as I know IP is changed by VPN, right? But I tried to type links with Opera's VPN active, I'm supposed to be seen as located in Canada, USA or whatever I suppose... but still, I get local language pages... 😞

  • Did you try clean up cookies and local data?

  • @leocg cookies, I delete regularly, by Browser settings.... not data: do you mean, all folders and files related to "Opera" under current user appdata folder, right? I guess I'd have to uninstall Opera before, then re-install.... I'll try! Never done before, honestly. Tnx for this suggestion: I'll try in next few hours! 🙂

  • Check in the Local. State file if the country code in country and country from server is correct.

  • (sorry for delay but I'm working during day, and not always with internet connection...)

    Well, I tried this:

    • unistalled Opera.
      -Gone il ocal data folder, and deleted entire Opera folder
      -re-installed Opera

    I lost all favourites, settings, history and so on... so, I guess EVERYTHING should be deleted and setted as default. But nothing changed.... I still get redirected to russian pages.... 😢

    Well, by friday I'll be back in Italy, so I'd no check any other options,for a couple of weeks... But I'll be back for sure in next journey, from somewhere around the world!
    Thank you, by now....

  • @patmat when i click that italian link it gets changed to uk
    but i notice the site has a selector at bottom of page try that maybe

    0_1548349585056_Capture.PNG