Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Mail not being marked as read

  • I just installed Opera Mail on my new system and it keeps my new mail marked "unread" after I open it. I want it to show as "read" after I open it so that I know what is new when I check my other devices.
    I use IMAP to my GMAIL account.
    I have used Mail on my other systems and it works fine. I know there has to be a setting somewhere, but I can't find it!
    Please help!!

  • If you are reading posts in Unread then you have to mark them read manually (so that they don't disappear out from under you). Easiest way would be a keyboard shortcut - there are several depending on which direction you want to move (you can see them on the context menu under Mark >).

  • Note that Opera mail has 3 states for read status: Unread + Unseen (Bold Blue Text), Unread + Seen (Bold Black Text) and Read (Black Text). When you open a message (in a new tab or when you select it in the message list and have the preview pane enabled), the message is marked as seen. Then, when you've actually read the content of the message, you can mark it as read with k. Opera can't know if you've actually read the message, which is why you mark it as read yourself. To make this work right though, you have to click the slanted wrench icon at the top right of Opera and set "Mark as read" to "manually". You should try using Opera this way first. It's different, but you should try it, especially if you're going to use Opera's All Messages views.

    Now, by default, you'll see that Opera has "mark as read" set to "1 second". This is to simulate other clients where opening a message implies reading by automatically marking a message as read when it's seen for 1 second. But, as noted, in Opera's "All Messages/Unread" view, when you mark a message as read, it disappears from the view, so Opera makes an exception for that case.

    The one downside of Opera's "seen" state for a message though is that it's local only. It's not synced with the IMAP server and the IMAP server doesn't support it.

    I use IMAP to my GMAIL account.

    Gmail IMAP is very special with how things behave. It doesn't exactly mix well with Opera's global views like the All Messages views. If you want Opera to behave like a typical IMAP client, in Opera's Mail panel, you can drag the you@gmail.com IMAP folder access point to the top and ignore all the other access points (including the "All Messages" access point). Then, you work with the IMAP folders like you would in a typical IMAP client or webmail.

  • @burnout426

    PERFECT!! The 1 sec setting was the issue. I just had my window too small and didn't see it!! Thank you so much!!

Log in to reply