Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Flash doesn't work

  • Hi guys. I wanted to try some browser games and it told me I need flash. So I installed it, as u can see:
    alt text
    Yet opera does not recognise it. Even Adobe's website in Opera does not find it
    alt text
    I went through settings and made sure it's enabled:
    alt text
    And yet it doesnt work.
    (Btw it's strange that when I return to the parent menu under flash it says 'ask first' as a run mode:
    ![alt text](0_1545663282282_8093d2da-38c6-471d-bcb5-d44d21df93c8-image.png image url)
    But as u can see in the previous shot I've not enabled this option so it can run directly without asking me. Something's messed up in Opera's flash policies)
    When I open a page with flash content I get this:
    alt text

    I also have Chrome and there it works fine. But I keep it for different browsing and rather run flash games in Opera. Can this be fixed?

  • Flash is blocked by default, you need to allow access to every site you want Flash to work in.

    You should see a bar on the page asking you to allow Flash to run on it. If you don't, them you need to add the site as an exception in opera://settings/content/flash

  • Goto the URL chrome://flags/#enable-ephemeral-flash-permission and disable it if you don't want your Flash permissions reset when you close Opera. Restart Opera after doing that.

    Then, go back to opera://settings/content/flash where you again turn on "Allow sites to run Flash' and turn off "ask" (if it changed on you), so that all sites can automatically run Flash. You then shouldn't have to add any exceptions. If you have any exceptions, you can clear them.

    That's the no-nonsense way to do it.

    However, if you want to block all Flash by default for security reasons (PPAPI plug-ins should be sandboxed in Opera, so you shouldn't have to worry that much), turn "ask" back on. Then, you can either manually add exceptions or click the plug-in placeholder on a page to enable Flash for the site. Or, when on the site, you can click the badge on the left side of the address field and enable Flash for the site in the site settings.

  • Opera assumes what you should want to do
    well screw that

  • It's Chromium decision to block Flash.