Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

'opera autoupdate' folder keeps showing up in Downloads folder

  • @louay-madanat Yes, I've tried several times already.
    What I am doing:

    1. Uninstalled Opera
    2. Deleted this folders:
    • \Users\Username\AppData\Local\Programs\Opera
    • \Users\Username\AppData\Roaming\Opera Software\Opera Stable
    • \Users\Username\AppData\Local\Opera Software\Opera Stable
    1. Cleaned \Windows\Temp and \Users\Username\AppData\Local\Temp
    2. Installed Opera_57.0.3098.102_Setup_x64.exe
    3. Syncronized into my account
    4. Rebooted
    5. Found reappeared "opera autoupdate" folder again 😩
  • Tried again 3 times with some variations of steps but still...
    I hope guys from Opera Software will fix this one day. Anyway this is not such a big problem.

  • @greemanik said in 'opera autoupdate' folder keeps showing up in Downloads folder:

    Syncronized into my account

    Wonder if it's caused by some setting that's getting synced back to the new Opera profile.

  • @burnout426 I also tried without syncronizing at all, but no.

  • I guess the only solution for now is to turn off autoupdate. I had the folder reappear today too so reinstalling didn't permanently fix it.

  • 😞 Some info that might help Opera.

    What OS? And, 64-bit or 32-bit?

    What version of Opera? And, 64-bit or 32-bit? Did you update to the newest?

    Where is Opera installed and where is its profile folder. Goto the URL opera://about to find out.

    What type of an account are you running Opera under? Is it an admin or standard/limited user?

    Do you have any extensions? If so, have you tried with them disabled?

    What's the path your download folder is set to in Opera? See the URL opera://settings/downloads. Also, is "Ask where..." enabled or disabled?

    Are you using Opera Sync? If so, does it happen with Opera Sync is disabled? (I know this has been answered previously)

    Close down Opera and rename your Opera profile folder so that you're starting with a new profile. Don't enable sync or anything in it. Just set your download folder (if not using the default location) and just use it for a while and see if you can reproduce the issue. Can you reproduce it? When done testing, close Opera, delete the profile folder and rename your old profile folder back to default so Opera can use it again. Alternatively, download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation", uncheck any boxes you want, and install. Test in that Opera. Does it trigger the issue there too?

    Does renaming the opera_autoupdater.exe file stop it from happening? (I think you said yes.)

    Hit the Windows Key + r, type cmd and press ENTER. Type set. What are the paths for TEMP, TMP and LOCALAPPDATA? Look at the other paths and see if anything looks like a non-default setting.

    If you goto the URL opera://update and click "check for updates", does that instantly trigger the creation of the "opera autoupdate" folder in your downloads folders?

    Running Opera with Sanboxie?

    Security software you're running?

  • @burnout426 Thanks a lot for the detailed post! Hope this helps.
    I didn't try everything (namely trying a new profile/installation) because the issue happens randomly and sporadically (went 5 days without it happening after reinstalling) and also it's not that major. If it happens again I'll try that step too.

    @burnout426 said in 'opera autoupdate' folder keeps showing up in Downloads folder:

    What OS? And, 64-bit or 32-bit?

    Windows 10 Home 64-bit

    What version of Opera? And, 64-bit or 32-bit? Did you update to the newest?

    57.0.3098.102, 64-bit (latest update)

    Where is Opera installed and where is its profile folder. Goto the URL opera://about to find out.

    Installed: AppData - Local - Programs - Opera
    Profile: AppData - Roaming - Opera Software - Opera Stable

    What type of an account are you running Opera under? Is it an admin or standard/limited user?

    Admin

    What's the path your download folder is set to in Opera? See the URL opera://settings/downloads. Also, is "Ask where..." enabled or disabled?

    Default path (User folder - Downloads). "Ask where..." disabled.

    Are you using Opera Sync? If so, does it happen with Opera Sync is disabled? (I know this has been answered previously)

    I am using Sync but haven't tried disabling it (since it's been done)

    Does renaming the opera_autoupdater.exe file stop it from happening? (I think you said yes.)

    I'm not sure it does actually. I'll have to test it for a while but I think it happened again after renaming.

    Hit the Windows Key + r, type cmd and press ENTER. Type set. What are the paths for TEMP, TMP and LOCALAPPDATA? Look at the other paths and see if anything looks like a non-default setting.

    LOCALAPPDATA: AppData - Local
    TEMP and TMP: AppData - Local - Temp

    Everything else is normal

    If you goto the URL opera://update and click "check for updates", does that instantly trigger the creation of the "opera autoupdate" folder in your downloads folders?

    No it doesn't, seems very random.

    Running Opera with Sanboxie?

    Nope

    Security software you're running?

    Used to be Bitdefender, now Avast.

  • @louay-madanat Okay. Sounds like you have a pretty-basic, default, current-user-only install.

  • C:\Users\USERNAME\opera autoupdate
    Thank you for dumping this all over my system disk...

  • @greemanik said in 'opera autoupdate' folder keeps showing up in Downloads folder:

    Rebooted
    Found reappeared "opera autoupdate" folder again

    Check the windows Task Scheduler. Is there an Opera task that's set to run when the system boots?

    Do you have Opera set to automatically start up when the system boots in some way?

    Also, check the startup tab in the windows Task Manager. Any Opera startup entries?

  • @burnout426 thanks for replying. I found this in my Task Scheduler:

    0_1545567521393_Π‘Π½ΠΈΠΌΠΎΠΊ.PNG

    No I don't have Opera set to autostart on boot.
    There are no Opera entries in Task manager.

  • Interesting. I don't have any scheduled tasks for my Opera. It's installed to "C:\Program Files\Opera" (the 64-bit version) (all users option in installer options) on Windows 10 Pro 64-bit. If I were you, I'd just delete them all. Then, see if they come back.

    Another thing you can do is look at the properties of those tasks. Perhaps they're starting the auto updater in the wrong working directory, which might explain the issue. Or, they're starting with a system/admin user and the environment they're started in has a incorrect temp directory or something.

    You might also want to run services.msc to see if there's an Opera service running. There shouldn't be, so if there is, disable it.

  • @burnout426 every single one of these tasks launches this: C:\Users\USERNAME\AppData\Local\Programs\Opera\launcher.exe
    with an argument: --scheduledautoupdate $(Arg0)

  • Okay. I was mistaken btw. I do have them in the Task Scheduler. I'll look at mine to see if I see anything weird with the settings for them.

  • @burnout426 i tried to launch them one after another and folders do not reappear
    But when I launch them all at the same time simultaneously then i have "opera autoupdate" folders reappear.. Strange

    also i checked services.msc as you said and i didn't find any Opera services

    1. uninstalled opera
    2. deleted all Opera tasks in Task Scheduler πŸ‘ˆ
    3. installed opera again
    4. Problem solved

    Now i have only one task and it works properly. After reboot folders do not reappear.
    Thanks @burnout426 for helping! πŸ‘

  • Awesome. Next time Opera updates, see if it just adds more tasks and doesn't clean up the old ones.

    I have quite a few task myself, so I'll probably delete all mine and reinstall to do the same just for good measure. I'll have more than one at least though as I have Opera Developer and Opera Beta installed too.

  • So some info from developer.
    In regular situation there shouldn't be multiple entries of scheduled tasks. Each installer should keep it clean and have only one task created. When multiple scheduled tasks are present described situation can occur. Each tasks first attempts to lock temp folder for it's process. If it is not possible it will try to lock downloads, home and folder with launcher.exe where it will store temporary autoupdate files.

  • @louay-madanat
    I have the same headache.

    Automatic update is an idiotic idea. I can disable such feature in just about every app β€” but NOT in Opera. This new version (66.0.3515.44) had the terrible idea of enforcing the automatic updating of the browser.

    The problem is Opera creates an Automatic Update folder in my Downloads folder every time I start the browser. I update my computer daily to external devices. That crappy Automatic Update folder of Opera gets always backed up to the external devices. I DO NOT WANT THAT!

    So, the Opera developers should remove this automatic updating feature from Opera. It was like that in the previous version. Clean and no headaches. Uninstalling and reinstalling this latest version is an aggravating factor β€” it does NOT clean up the mess.

    Opera version: 66.0.3515.44
    OS: 64-bit Windows 10 Pro, version 1909

    Ion Saliu
    β€œA good man is an axiomatic man; an axiomatic man is a happy man. Be axiomatic!”

  • @parpaluck said in 'opera autoupdate' folder keeps showing up in Downloads folder:

    I have the same headache.

    Did you check the Windows Task Scheduler to make sure you only have one Opera scheduled task? If you have more than one for a single release channel of Opera, that's your problem and you need to delete one. Or, delete both and then reinstall Opera.

    Automatic update is an idiotic idea. I can disable such feature in just about every app β€” but NOT in Opera.

    Close down Opera and make sure no Opera autoupdate process is shown in the Windows Task Manager. Then, in Opera's program files folder in the latest version folder, delete opera_autoupdate.exe. You can also delete the Opera scheduled task after that if you want too (not necessary though).

    Repeat after any time you manually update Opera.

    Once you have the autoupdate disabled, clear the autoupdate folder in the downloads folder and it won't come back. But, just for good measure, also delete all files and folders in "C:\Windows\temp" and "C:\Users\yourusername\AppData\Local\temp" to get rid of any old, Opera installer files and folders.

    Not the best solution, but it'll solve the problem for you.

Log in to reply