Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

Hello, in order to introduce new security features and enhance your experience with Opera Forums we have to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button in the upper-right corner of the page.
This is a one-time action. Sorry for any inconvenience!

Opera doesn't recognise itself

  • @temkem

    thank you for the suggestion. No such luck. I also checked the executable itself, and tried launching directly - no change.

  • @aspiring-squirrel said in Opera doesn't recognise itself:

    Playing around with user agent switcher (for Chrome)

    Link to specific extension?

    Can you try another browser to see if it's also affected? Maybe there's something installed on your system. Maybe check task manager, check LAN proxy settings in Internet Options, HOSTS file and TCP/IP settings for your LAN adapter.

    After uninstalling Opera and having it delete all your data, and cleaning up an files and directories left, did you check out the registry and remove all the Opera keys?

    Can you search the registry for the user-agent string that Opera is identifying as?

    Download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation", uncheck "import bookmarks" and install. Does it also have there? If so, launch a command-prompt, cd to the directory on the desktop and run launcher.exe --no-proxy-server. Any difference then? Try --disable-extensions too if you want.

    Temporarily create a new Windows user account and run Opera there? Is Opera affected in that case? If not, it's most likely something in your normal user account.

    Maybe check for malware.

  • @burnout426

    Thank you very much for the suggestions. Been through most of that already but never hurts to doublecheck, especially to confirm for troubleshooting.

    Extension in question: https://chrome.google.com/webstore/detail/user-agent-switcher-for-c/djflhoibgkdhkhhcedjiklpkjnoahfmg

    Apologies for not including link in original post!

    All settings seem OK as far as I can see, nothing unusual in Task Manager either, and nothing reported by malware scans (Kaspersky and Malwarebytes)

    Firefox (installed and used before) and Chrome (after) are both unaffected.

    Did regular uninstall and hunted down remnants. Used uninstall program (Revo Uninstaller) and hunted down remnants after it was done. No change.

    Tried standalone installation and temp new windows account - no change. Used suggested arguments with launcher - no change.

    I'm torn between, it's something right in front of my face and I'll say a bad word when I find it, and, meh, maybe I should just move to a new browser and try returning to Opera in the future (been using it on and off since it was a paid app, so I am somewhat attached)

    Thanks again for the assistance.

  • What does https://www.whatsmyua.info/ say for your user agent?

    If you goto addons.opera.com, ctrl + shift + i to open the developer tools, type navigator.userAgent in the console and press enter, what does it say for the UA? Maybe it's fine and the site is just being goofy for you. Maybe restart your modem or something to see if you can get a different ip address and then go to addons.opera.com.

    I checked out the extension. I don't see anything weird about it. In Chrome though, its settings and probably the extension itself can be synced if you're using Google Sync. So, with Chrome, if you started with a fresh profile and turned on sync, the extension my be enabled again on you. But, that shouldn't affect Opera either way.

  • @burnout426

    Sorry for the slow reply!

    According to useragent v2.1.9:
    ua
    rawUa: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36
    string:
    family: Chrome
    major: 69
    minor: 0
    patch: 3497
    device: Other 0.0.0

    console when browsing addons.opera.com reports same
    navigator.userAgent
    "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36"

    Tested with and without VPN (privateinternetaccess) and with a new router - not bought because of this, just happened to upgrade 🙂

  • Did you try a reinstall?

  • @leocg

    Several times, as both standalone and regular install.

  • Try creating a new Windows user and check if the problem also happens with it.

  • @leocg tried that as well, per an earlier suggestion by burnout426. Produced the same result.

  • @aspiring-squirrel said in Opera doesn't recognise itself:

    According to useragent v2.1.9:

    It's definitely missing the OPR/... part. Are you downloading Opera from opera.com (as opposed to some 3rd-party site)?

  • @burnout426
    Yes, directly from Opera.

  • Hmm. Goto the URL data:text/plain,test. Then, hit ctrl + shift + i, goto the Console tab and enter navigator.userAgent there. Is the OPR/... missing from the user agent in that case too?

  • @burnout426 0_1543428355167_opr.JPG

    Thanks again for your patience in trying to sort this out.

  • @aspiring-squirrel Okay. Since the opr part is there for the data URL, I'm guessing the issue only affects https and http URLs. This leads me to believe that it's something outside of Opera that's causing it and targeting Opera specifically or targeting Chromium user-agents specifically (and modifying them to remove anything extra like the opr part). If not malware (as you scanned for it for example), all I can think of at the moment is some Chrome/Opera policy in the registry or something to do with your router or something to do with your ISP.

  • Did you want to try and uninstall Opera and then remove Opera stuff from the registry?

  • @burnout426

    I'm willing to give some registry editing shot, I have a feeling that is where the problem is.

    Never had a problem with the ISP before, and actually just swapped out the router the other day.

    • Delete Opera keys under "HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet".

    • Delete "HKEY_LOCAL_MACHINE\SOFTWARE\Opera Software".

    • Delete Opera strings from "HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications".

    Do the same for those Opera keys and strings under "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node".

    • Delete "HKEY_LOCAL_MACHINE\SOFTWARE\Classes\OperaStable".

    • Delete "HKEY_CURRENT_USER\Software\Opera Software".

    • Delete Opera strings if they're in "HKEY_CURRENT_USER\Software\RegisteredApplications".

    • Delete "HKEY_CURRENT_USER\Software\Classes\OperaStable".

    • Delete "HKEY_CLASSES_ROOT\OperaStable".

    • Delete "HKEY_CLASSES_ROOT\Applications\opera.exe".

    • Delete Opera entries in "HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache".

    • Delete Opera entries in "HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\MuiCache".

    • Delete launcher.exe entries in "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ApplicationAssociationToasts".

    • Delete Opera entries in "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search\JumplistData".

    • Delete Opera entries in "HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Store".

    • Delete "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\opera.exe".

    • Delete Opera entries "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\UFH\ARP".

    • Delete Opera enttries from "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted".

    • Delete "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\App Paths\opera.exe".

    • Delete Opera keys in "HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall".

    • Delete "HKEY_USERS.DEFAULT\Software\Classes\OperaStable".

    Look for any "Opera Developer" and "Opera Beta" keys and remove those too.

    • Delete "HKEY_CLASSES_ROOT\Applications\Launcher.exe".

    Look for any of those keys/entries under any of the other users listed in the registry and remove those Opera ones too.

    In Explorer, delete "C:\Program Files\Opera", "C:\Program Files (x86)\Opera", "C:\Users\yourusername\AppData\Roaming\Opera Software", and "C:\Users\yourusername\AppData\Local\Opera Software". Delete any "Opera Developer" and "Opera Beta" folders too.

    • Delete any Opera files and folders in "C:\Windows\Temp".

    • Delete all the files that you can in "C:\Users\yourusername\Appdata\Local\temp".

    • Delete any Opera folders in "C:\Users\yourusername\Appdata\Local\programs".

    Opera should then be pretty clean from the system. Then, download the Opera installer, launch it, click "options", set "install path" to "C:\Program Files\Opera", set "install for" to "all users", uncheck "import data" and anything else you want to uncheck and then install. Then try Opera in its default state.

    Then, you'd reinstall Opera.

    Now, you could use a registry cleaner to do the registry stuff first and then check for leftovers. But, this way, you can manually check everything you're going to delete.

  • If after doing all that and reinstalling Opera, if it still doesn't work, you might try a registry cleaner. CCleaner can do some cleaning, but there's a better one that often fixes issues. I just can't remember the name of it. Maybe some others have some suggestions.

    Maybe it was https://www.auslogics.com/en/software/registry-cleaner/.

  • @burnout426

    going through registry now. Noticed this on the way:

    {
    "name": "com.microsoft.browsercore",
    "description": "BrowserCore",
    "path": "BrowserCore.exe",
    "type": "stdio",
    "allowed_origins": [
    "chrome-extension://ppnbnpeolgkicgegkbkbjmhlideopiji/",
    "chrome-extension://ndjpnladcallmjemlbaebfadecfhkepb/"
    ]
    }

    C:\Program Files\Windows Security\BrowserCore\manifest.json

    not sure if related (Chrome not installed currently)

  • @aspiring-squirrel I have that too and I think it's legit. See https://forum.adlice.com/index.php?topic=3340.msg7567#msg7567 for example.

Log in to reply