Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera doesn't recognise itself

  • Playing around with user agent switcher (for Chrome), reset it and removed from extensions as it did not seem to be what I needed. Since then, Opera is behaving oddly. I can't download addons ("You need the Opera browser") and if I check a site like whatismybrowser it tells me I am using an outdated version of Chrome. Tried uninstalling and reinstalling, no luck. Tried uninstalling, hunting down remnants and then reinstalling, still no luck. Even tried using other user agent switchers, still no.

    I can't figure out how to fix this and it is driving me nuts. Any assistance greatly appreciated, thank you.

  • Did you try with a clean profile?

  • @leocg

    Yeah, I deleted the existing profile for a completely fresh install. Just checked again (renamed profile folder to force fresh) and still no luck

    Version:56.0.3051.104
    Opera is up to date
    Update stream:Stable
    System:Windows 10 64-bit
    Rate Opera
    Browser identification
    Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36 OPR/56.0.3051.104

    Detects as Chrome 69.

  • On any site? Not all of them can detect Opera correctly and detect Opera as Chrome.

  • @leocg

    Yes, even Opera / Opera Addons tells me "Opera required. Download it now."

    0_1542761301619_opera required.JPG

  • @aspiring-squirrel Check the shortcut from which you are launching Opera.
    Perhaps in the "properties" of the shortcut, the User Agent from the Chrome browser is registered in the "object" field.

  • @temkem

    thank you for the suggestion. No such luck. I also checked the executable itself, and tried launching directly - no change.

  • @aspiring-squirrel said in Opera doesn't recognise itself:

    Playing around with user agent switcher (for Chrome)

    Link to specific extension?

    Can you try another browser to see if it's also affected? Maybe there's something installed on your system. Maybe check task manager, check LAN proxy settings in Internet Options, HOSTS file and TCP/IP settings for your LAN adapter.

    After uninstalling Opera and having it delete all your data, and cleaning up an files and directories left, did you check out the registry and remove all the Opera keys?

    Can you search the registry for the user-agent string that Opera is identifying as?

    Download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation", uncheck "import bookmarks" and install. Does it also have there? If so, launch a command-prompt, cd to the directory on the desktop and run launcher.exe --no-proxy-server. Any difference then? Try --disable-extensions too if you want.

    Temporarily create a new Windows user account and run Opera there? Is Opera affected in that case? If not, it's most likely something in your normal user account.

    Maybe check for malware.

  • @burnout426

    Thank you very much for the suggestions. Been through most of that already but never hurts to doublecheck, especially to confirm for troubleshooting.

    Extension in question: https://chrome.google.com/webstore/detail/user-agent-switcher-for-c/djflhoibgkdhkhhcedjiklpkjnoahfmg

    Apologies for not including link in original post!

    All settings seem OK as far as I can see, nothing unusual in Task Manager either, and nothing reported by malware scans (Kaspersky and Malwarebytes)

    Firefox (installed and used before) and Chrome (after) are both unaffected.

    Did regular uninstall and hunted down remnants. Used uninstall program (Revo Uninstaller) and hunted down remnants after it was done. No change.

    Tried standalone installation and temp new windows account - no change. Used suggested arguments with launcher - no change.

    I'm torn between, it's something right in front of my face and I'll say a bad word when I find it, and, meh, maybe I should just move to a new browser and try returning to Opera in the future (been using it on and off since it was a paid app, so I am somewhat attached)

    Thanks again for the assistance.

  • What does https://www.whatsmyua.info/ say for your user agent?

    If you goto addons.opera.com, ctrl + shift + i to open the developer tools, type navigator.userAgent in the console and press enter, what does it say for the UA? Maybe it's fine and the site is just being goofy for you. Maybe restart your modem or something to see if you can get a different ip address and then go to addons.opera.com.

    I checked out the extension. I don't see anything weird about it. In Chrome though, its settings and probably the extension itself can be synced if you're using Google Sync. So, with Chrome, if you started with a fresh profile and turned on sync, the extension my be enabled again on you. But, that shouldn't affect Opera either way.

  • @burnout426

    Sorry for the slow reply!

    According to useragent v2.1.9:
    ua
    rawUa: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36
    string:
    family: Chrome
    major: 69
    minor: 0
    patch: 3497
    device: Other 0.0.0

    console when browsing addons.opera.com reports same
    navigator.userAgent
    "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36"

    Tested with and without VPN (privateinternetaccess) and with a new router - not bought because of this, just happened to upgrade 🙂

  • Did you try a reinstall?

  • @leocg

    Several times, as both standalone and regular install.

  • Try creating a new Windows user and check if the problem also happens with it.

  • @leocg tried that as well, per an earlier suggestion by burnout426. Produced the same result.

  • @aspiring-squirrel said in Opera doesn't recognise itself:

    According to useragent v2.1.9:

    It's definitely missing the OPR/... part. Are you downloading Opera from opera.com (as opposed to some 3rd-party site)?

  • @burnout426
    Yes, directly from Opera.

  • Hmm. Goto the URL data:text/plain,test. Then, hit ctrl + shift + i, goto the Console tab and enter navigator.userAgent there. Is the OPR/... missing from the user agent in that case too?

  • @burnout426 0_1543428355167_opr.JPG

    Thanks again for your patience in trying to sort this out.

  • @aspiring-squirrel Okay. Since the opr part is there for the data URL, I'm guessing the issue only affects https and http URLs. This leads me to believe that it's something outside of Opera that's causing it and targeting Opera specifically or targeting Chromium user-agents specifically (and modifying them to remove anything extra like the opr part). If not malware (as you scanned for it for example), all I can think of at the moment is some Chrome/Opera policy in the registry or something to do with your router or something to do with your ISP.