Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • I can no longer open Opera on my MacBook Pro [Mac OS X 10.14 (18A391)]. Worked fine until I restarted the browser late last night. Clicking its icon yields a similar crash message every time. Restarting the laptop didn't solve the issue.

    Not used to troubleshooting on a Mac -- does Opera have a safe mode? Tried looking for one to no avail.

    Thinking about it more, I seem to recall Opera requesting my pw to update itself at some point in the last few days, but I didn't restart Opera until late last night.

    Full error message:

    Process:               Opera [4137]
    Path:                  /Applications/
    Identifier:            com.operasoftware.Opera
    Version:               56.0 (56.0.3051.35)
    Code Type:             X86-64 (Native)
    Parent Process:        ??? [1]
    Responsible:           Opera [4137]
    User ID:               1318860973
    Date/Time:             2018-10-03 09:19:43.529 -0700
    OS Version:            Mac OS X 10.14 (18A391)
    Report Version:        12
    Anonymous UUID:        F7CBA77F-B830-CF51-1D84-F8FACD7B1007
    Time Awake Since Boot: 34000 seconds
    System Integrity Protection: enabled
    Crashed Thread:        0  Dispatch queue:
    Exception Type:        EXC_CRASH (SIGABRT)
    Exception Codes:       0x0000000000000000, 0x0000000000000000
    Exception Note:        EXC_CORPSE_NOTIFY
    Application Specific Information:
    abort() called
    Thread 0 Crashed:: Dispatch queue:
    0   libsystem_kernel.dylib        	0x00007fff659e9b86 __pthread_kill + 10
    1   libsystem_pthread.dylib       	0x00007fff65a9fc50 pthread_kill + 285
    2   libsystem_c.dylib             	0x00007fff659531c9 abort + 127
    3   com.operasoftware.Opera       	0x000000010bdb4d9a 0x10bdb4000 + 3482
    4   libdyld.dylib                 	0x00007fff658ab085 start + 1
    Thread 0 crashed with X86 Thread State (64-bit):
      rax: 0x0000000000000000  rbx: 0x000000011a9675c0  rcx: 0x00007ffee3e4bb18  rdx: 0x0000000000000000
      rdi: 0x0000000000000307  rsi: 0x0000000000000006  rbp: 0x00007ffee3e4bb50  rsp: 0x00007ffee3e4bb18
       r8: 0x00000000000130a8   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000206
      r12: 0x0000000000000307  r13: 0x0000600000d79110  r14: 0x0000000000000006  r15: 0x000000000000002d
      rip: 0x00007fff659e9b86  rfl: 0x0000000000000206  cr2: 0x00007fff97947188
    Logical CPU:     0
    Error Code:      0x02000148
    Trap Number:     133
    Binary Images:
           0x10bdb4000 -        0x10bdb4ffb +com.operasoftware.Opera (56.0 - 56.0.3051.35) <674A6B89-8C1F-3E29-B3D9-E437B1210E1E> /Applications/
           0x11a8b1000 -        0x11a92f6a7  dyld (625.13) <D6387150-2FB8-3066-868D-72E1B1C43982> /usr/lib/dyld
        0x7fff34b0d000 -     0x7fff34b0dfff (1.11 - Accelerate 1.11) <2C602CED-72CA-37C2-BDF5-31697FC9100B> /System/Library/Frameworks/Accelerate.framework/Versions/A/Accelerate
        0x7fff34b25000 -     0x7fff351c5fe3 (8.1 - ???) <65912AFB-D4C1-3494-AE97-DDFDAF3BE1EB> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vImage.framework/Versions/A/vImage
    ... [truncated] ...
    External Modification Summary:
      Calls made by other processes targeting this process:
        task_for_pid: 0
        thread_create: 0
        thread_set_state: 0
      Calls made by this process:
        task_for_pid: 0
        thread_create: 0
        thread_set_state: 0
      Calls made by all processes on this machine:
        task_for_pid: 22631
        thread_create: 0
        thread_set_state: 0
    VM Region Summary:
    ReadOnly portion of Libraries: Total=364.0M resident=0K(0%) swapped_out_or_unallocated=364.0M(100%)
    Writable regions: Total=546.2M written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=546.2M(100%)
                                    VIRTUAL   REGION 
    REGION TYPE                        SIZE    COUNT (non-coalesced) 
    ===========                     =======  ======= 
    Kernel Alloc Once                    8K        2 
    MALLOC                           154.1M       11 
    MALLOC guard page                   16K        5 
    MALLOC_NANO (reserved)           384.0M        2         reserved VM address space (unallocated)
    STACK GUARD                       56.0M        2 
    Stack                             8192K        2 
    __DATA                            23.6M      223 
    __FONT_DATA                          4K        2 
    __LINKEDIT                       216.2M        4 
    __TEXT                           147.8M      224 
    __UNICODE                          560K        2 
    shared memory                        8K        3 
    ===========                     =======  ======= 
    TOTAL                            990.2M      470 
    TOTAL, minus reserved VM space   606.2M      470 
    Model: MacBookPro11,1, BootROM MBP111.0146.B00, 2 processors, Intel Core i5, 2.6 GHz, 16 GB, SMC 2.16f68
    Graphics: Intel Iris, Intel Iris, Built-In
    Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x802C, 0x31364B544631473634485A2D314736453120
    Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x802C, 0x31364B544631473634485A2D314736453120
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x112), Broadcom BCM43xx 1.0 ( AirPortDriverBrcmNIC-1305.2)
    Bluetooth: Version 6.0.8f6, 3 services, 18 devices, 1 incoming serial ports
    Network Service: Wi-Fi, AirPort, en0
    Serial ATA Device: APPLE SSD SM0256F, 251 GB
    USB Device: USB 3.0 Bus
    USB Device: Apple Internal Keyboard / Trackpad
    USB Device: BRCM20702 Hub
    USB Device: Bluetooth USB Host Controller
    USB Device: Natural® Ergonomic Keyboard 4000
    USB Device: USB Receiver
    Thunderbolt Bus: MacBook Pro, Apple Inc., 17.2
  • @brymstarr

    Me too. Exact same symptoms. Updated the browser today, then restarted browser (and computer, by coincidence). Now Opera crashes instead of launching. My crash log is the same (see below). If I login to the mac as admin user, Opera is ok, but not as my main (non-admin) user. And of course I need to run day to day as non-admin.

    Thread 0 Crashed:: Dispatch queue:
    0 libsystem_kernel.dylib 0x00007fff77473b66 __pthread_kill + 10
    1 libsystem_pthread.dylib 0x00007fff7763e080 pthread_kill + 333
    2 libsystem_c.dylib 0x00007fff773cf1ae abort + 127
    3 com.operasoftware.Opera 0x0000000105d13d9a 0x105d13000 + 3482
    4 libdyld.dylib 0x00007fff77323015 start + 1

  • @reader

    Online incremental update (and fresh install) of Opera 56 resulted in my main (non-admin) user always crashing quickly after launching Opera. Used admin user to move Opera application bundle to the trash followed by using offline installer => that allowed Opera 56.0.3015.36 application bundle to work for non-admin user.

    Keep Smiling 🙂

  • @ks4j
    That fixed my issue

  • Fixed mine too. Thank you!

  • Topic closed as solved.