Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

"Disable tab bar's top spacing" isn't working.

  • I'm using Opera on 3000x2000 resolution, 175% DPI scaling. When I switch to 100% scaling the setting works fine, but at 175% (which is what I use) there's still that pixel-wide space at the top of the tab bar that doesn't let me switch tabs by clicking on the top edge of the screen. The setting does literally nothing to solve that.

    Please fix this. Other people have complained about this too. It's literally the only thing preventing me from switching to Opera and never looking back, since everything else is pretty much perfect for me.

    Actually, do Opera employees ever check the forum? Do they ever reply to these posts?

  • @louay-madanat said in "Disable tab bar's top spacing" isn't working.:

    Actually, do Opera employees ever check the forum?

    Yes

    Do they ever reply to these posts?

    Usually they don't but it may happens sometimes.

  • @leocg Thanks, good to know. Do you know of any way to get the Opera team's comment on this? Whether it's being worked on or not and if so, when to expect a fix. Also I can help provide more info about it.

  • They will comment if they find out it's necessary.

  • @leocg So there's no way of knowing if it's being worked on? (sorry for all the questions)

  • Is this related to the 1-pixel border that has appeared along the top of the tab bar (when maximised) since updating from O55 to O56? I just noticed it upon updating and it's driving me nuts.
    Personally, I never figured out what "Disable tab bar's top spacing" ever did, as, though the option's been there forever, I never noticed any change whether it was enabled or disabled. Anyone know what it's supposed to do?

  • If the problem is being commented on the forums and/or on the blog, then it probably have been reported and someone should be looking into it.

  • Allow you to click on the tab when the cursor is on the very top of the screen.

  • @darthagnon (when it works, at least.)

  • @leocg said in "Disable tab bar's top spacing" isn't working.:

    Allow you to click on the tab when the cursor is on the very top of the screen.

    Thanks, leocg! I just tested it, and it seems to work for me - I'm on Win10 v1709, with a 1920x1080 HiDPI monitor, and 125% scaling. I have, however, gained a 1px border at the top of my tab bar since updating to O56 (was also connected to a 1440p external monitor at the time) - don't know might be it's related, since in Win10, this 1px border should only appear when a program is not maximised - maybe there's some problem with the latest Opera related to how it detects if it's maximised, which is possibly also related to high resolution monitors (e.g. louay-madanat has a hi-res monitor; I was connected to a hi-res monitor at the time of the update). See my attached screenshot for the 1px yellow line at the top that shouldn't be there while maximised... I'll come back and update if it remains after a restart.
    0_1538602435300_2018-10-03 22_26_01-Greenshot.png

  • The maximisation problem/1px line still persists after a restart. I'll open a new topic, as it seems to be a different issue, since tab bar spacing was working for me...

  • I mean I just switched back to Chrome. Doesn't seem like this will be fixed anytime soon since it's been there for a long time.

  • It seems fixed in today's developer build, should reach stable channel soon I guess.

  • Oh no way, that's great to hear! Definitely didn't expect it to be fixed this soon. I guess they do listen 🙂

    Thanks for letting me know leocg!

Log in to reply