Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera mail send mail twice

  • Hi, I can´t fix this issue: if i send a email to a destinatary he isn´t in my contact list, the email is sent twice.
    Any suggestions about what to do?

  • So you are saying that the recipient gets the message twice?

  • I remember this bug (if the recipient actually receives the message twice). But, I forgot how to trigger it. Something to do with a contact that has multiple addresses or something like that.

    You could try this though. "Menu -> Settings -> Import and export -> Export Contacts". Then, select all contacts in the contacts panel and trash them. Then, empty the trash. Then restart Opera Mail. Then, compose a new message to a person and send it to see if it still sends twice. If not, it's something to do with one of the contacts. When you're all done, you can import your contacts back in.

  • @leocg No, I say if i send a mail to a unknown destinatary, the destinatary gets the email twice and in my sent box it appears as sent twice.

  • @alvaritoash Can you confirm with the recipient that they get the message twice and it's not just something in Opera?

    Are you using Gmail IMAP?

  • @burnout426 I confirm that the message appears twice in my sent box. I use hotmail imap?
    Sorry but i thought the destinatary gets the message twice but i have confirmed that the destinatary gets the email once.

  • @alvaritoash said in Opera mail send mail twice:

    I use hotmail imap?

    On the "outgoing" tab in the account's properties in Opera Mail, do you have "Sent Items" set as the IMAP sent folder?

  • @burnout426 Yes, i have set sent items as the imap sent folder. If i set the sent items in white, i get the same result.

  • @alvaritoash said in Opera mail send mail twice:

    If i set the sent items in white, i get the same result.

    If you set it to white (as in, no sent folder set), close out of the mail account properties to save the change and then restart Opera, does it stay white or does it revert back to "Sent items" on you?

    I was thinking that the Hotmail SMTP server adds a copy of the sent message to "Sent Items" itself and when you have "Sent Items" set as the IMAP sent folder, Opera adds a copy also. If that's the case though, then not setting an IMAP sent folder in Opera should get rid of the one copy (you won't be able to control the copy the SMTP server generates). However, you said blanking out the IMAP sent folder setting in Opera doesn't help, so that's probably not the issue unless the sent folder is getting set to "Sent Items" again on you.

    I'll have to play with my hotmail account more and see what I can find. I don't use it very often.

  • I can confirm. Hotmail uses an MS exchange server (with IMAP turned on obviously). When you send a message through smtp-mail.outlook.com, the server automatically creates a copy of the sent message in the sent folder ("sent" on IMAP, "Sent items" at outlook.com). That's the one copy.

    The other copy is the one that Opera appends to the IMAP "sent" folder. This is what Opera is supposed to do. Unfortunately, Opera doesn't have an IMAP "don't place copy of message in sent" folder option to work around servers that create the copy themselves.

    Now, you can unset the sent folder on the IMAP tab in the account's properties. But, then Opera will no longer treat messages in that IMAP sent folder as sent. Further, in the case of exhange IMAP, Opera doesn't let you keep the sent folder unset. It'll get set again. I even tried closing down Opera and editing incomingN.txt for the account to disable special use (server doesn't seem to be using it) so the sent folder isn't forced. But, that doesn't help. And, even if you can blank out the sent folder setting for a bit, it gets turned back to "sent" all the while still placing a copy on the server.

    Long story short, you can't avoid the having 2 copies with Opera mail. You can't even hide them by unchecking "show duplicates" because they're not true duplicates. The copy the server creates has a whole bunch of ms-exchange headers in it. All you can do is hide the server-created copy with a label set to "hide these messages from other views" (with "apply only to new" unchecked) set, with "show hidden" unchecked for your sent views with the following rules for the label:

    From header contains you@example.com
    and
    any header contains x-ms-exchange
    

    There is a does not contain rule where you can try to hide Opera's copies instead. You'll have to play with that.

    That's about it.