Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Widevine and Opera

  • Opera for linux, does not come with widevine. Please mods, don't try to tell people it does.

  • Where does it say that opera comes with widevine support? It is even written in the relevant config file that it uses chrome's libs to get widevine support!

    $ cat /usr/lib/x86_64-linux-gnu/opera/resources/widevine_config.json[
       {
          "preload" : "/opt/google/chrome/libwidevinecdm.so",
          "plugin" : "/opt/google/chrome/libwidevinecdmadapter.so"
       },
       {
          "preload" : "/opt/google/chrome-beta/libwidevinecdm.so",
          "plugin" : "/opt/google/chrome-beta/libwidevinecdmadapter.so"
       },
       {
          "preload" : "/opt/google/chrome-unstable/libwidevinecdm.so",
          "plugin" : "/opt/google/chrome-unstable/libwidevinecdmadapter.so"
       }
    ]
    
  • @jimunderscorep I know it takes the pluging from Chrome. I'm saying the mods tell the people that usually Opera comes with widevine and maybe is a problem with their computer.

    @sgunhouse said in Opera & Netflix:

    Opera includes widevine, you shouldn't need that.

    @leocg said in Opera & Netflix:

    @yaute It means that for some reason Widevine isn't being downloaded.

    If you have Chrome or other Chromium based browser, try copying its Widevine directory to Opera's profile directory.

  • I can download chrome's deb package, extract the libwidevine* libs and place it in opera's profile directory as suggested by leocg. But how will I know widevine support works? I do not have a netflix account for instance...

  • So, I did what I said earlier.
    I downloaded chrome's deb, extracted libwidevinecdm from it (there is no libwidevinecdmadapter file in the package), copied it to ~/.config/opera, visited this site here

    https://bitmovin.com/demos/drm

    and it reports "no drm".

    0_1537346460487_2018-09-19-113842_1280x1024_scrot.png

    So it does not work, so we'd better ignore that advice from leocg.

    Then I created the folder /opt/google/chrome, moved the file in there, reopened the page but still no luck.

    Verdict? If you do want to watch drm content on linux, use another browser,

    On the same page, firefox prompted me to download something, I allowed it to and a few moments later, the stream started playing, in all its 3 variations. It even says "widevine" instead on "no drm"!

    0_1537346674444_2018-09-19-114142_1280x1024_scrot.png

    Chromium, on the other hand, does play the streams despite mentioning "no drm". Now that is odd...

    0_1537346838454_2018-09-19-114220_1280x1024_scrot.png

  • Mods are users like any other, they don't know everything and they may say something wrong sometimes.

    In my case, since Opera comes with Widevine on Windows and, I guess,, on Mac too, I thought it was also the case with Linux.

  • I agree with you on that and I accept your apology 🙂

    However, if you are not a linux user or an opera dev for the linux version, please do not generalize facts based on your experience on a different os. Windows or mac may have widevine support due to some system wide libs, linux doesn't

  • As of chromium v67, libwidevinecdmadapter.so is obsolete.
    But, when opera did work with widevine, it required a ua switch from command line startup switch (--user-agent) or an extension ua switcher. Nothing works as of late.

    For Chromium, I added under /usr/lib/chromium: ln -s /opt/google/chrome/libwidevinecdm.so, just for good measure. No ua masking was needed. It worked fine with netflix.

    So, they need to add the sites that use widevine to their ua masks, and fix the obsolete code.

  • My biggest question is why do they ship it for windows and mac but not linux?.