Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to fix Screen keyboard appears

  • Screen keyboard appears every time when I open page with input field or click left mouse button in this field. Normal keyboard works correctly. IE works correctly, notepad etc.
    beheviour like smartphone.. tried to repair Opera - without result
    Netbook computer with touchscreen.
    Thank you in advance

  • want to type - but I do not need it! It become works like smartphone. Other applications do not work this way so it is Opera's problem.
    I use netbook with touchscreen. This behaviour starts several days ago. The strange thing - my friend use Chrome on netbook and faced with same problem also last days.. What is it?

  • This post is deleted!
  • Same problem here with desktop version of Opera. It's very annoying..

  • is it possible to reinstall Opera without affecting history, favorits etc?

  • Yes, it is.

  • @vat

    I have the same issue. Hey Opera people, listen to us! Please disable OSK if the system has physical keyboard. Earlier it was working exactly this way.

    By now, there is a workaround. You will need a Microsoft Devcon script.

    1. Create a folder, let's say C:\touch
    2. Download devcon from Microsoft:
    3. Create a *.bat file in \touch folder:
      set "touchscreenid=HID\VID_03EB&PID_8204&MI_00"
      devcon status "%touchscreenid%" | findstr "running"
      if %errorlevel% == 0 (
      devcon disable "%touchscreenid%"
      ) else (
      devcon enable "%touchscreenid%"
    4. Please note that HID\VID_03EB&PID_8204&MI_00 is the HID signature of my own Toshiba touchscreen. Most likely yours will have different HID! You can fetch your touchscreen HID from Device Manager tool and then replace this value in the script above.
    5. Now, create a shortcut to the script.bat file with the script:
      C:\Windows\System32\cmd.exe /C "C:\touch\script.bat"
    6. Click on that shortcut each time you are connected to the physical keyboard and when you're about to disconnect.

    Of course this shortcut-clicking thing is annoying as ***k, but at least it will help you while Opera people are working on the regular fix.

  • I disabled touchscreen in device manager. Now it is possible to use netbook. But sometimes I need touchscreen to zoom. So this is semisolution.. If designers are working to fix problem?