Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How do I block Google from coming back?

  • I set a search engine as my default/preferred SE. However, if I mistyped URL, Google announces itself with a popout (see image below) "This site can't be reached..." and to use to use Google to try a search of it's catalogue 🤬 .
    How do I change it to my preferred SE again, or eliminate/delete/prevent Google from muscling in again?

    My settings are "Settings > Browsewr > Bing. Unfortunately, under "Manager Search Engines", where I found Google, is no option to terminate Google, or any SEs. Bing is my "default".

    I know what the typo is in the url, and I know I don't want Google butting in.

    Thanks for your time,
    i

    alternate text

  • I think you can't change the search engine used in the error pages.

  • This worked, it was bumming the crap out of me that I could turn it off. Thanks mate

  • @leocg said in How do I block Google from coming back?:

    I think you can't change the search engine used in the error pages.

    Thanks. I feel like a kid in a high-chair being spoon-fed anti-privacy browsers by corporate peeps. There must be a browser with a way to avoid Stalkers without the extra costs. I'll keep looking - thanks again.

  • This post is deleted!
Locked