Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 55: Disable Click-To-Play For Flash?

  • I can't figure out how to get rid of the play button for flash to run. It is very inconvenient. Everything I looked up about it says there is an option For click-to-play in plugin settings but such a setting does not seem to exist in this version. Does anyone know how to disable this?

  • Bump?

  • Make sure you goto https://get.adobe.com/flashplayer/ in Opera to download and install the version of Flash that Opera needs. Make sure to uncheck "optional offer" on that page.

    When you're on the site in question, click the icon/badge at the left side of the address field, goto "site settings", change "Flash" from "ask" to "allow".

    Or, you can goto opera://settings/content/flash and add to the allow list manually. If you just want all sites to run Flash so you don't need to add exceptions, turn off "ask" there.

    You may see a "plug-in blocked" badge on the right-side of the address field that you have to click and choose "run this time" where you'll have to do it each time a page loads. This is because the site is trying to put small/hidden Flash objects on the page, which might be dangerous. To get around always having to do this, you can use the "Always Activate Flash" extension mentioned below.

    There's a setting at opera://flags/#flash-detection-through-navigator-plugins that's enabled by default to help sites detect Flash better. But, sometimes it can mess up detection. If everything else fails, you can turn it off to see if it helps. If it doesn't, turn it back on.

    Maybe the site has a problem detecting Opera as a Chromium browser. If so, you can use this extension to mask as Chrome to see if that helps.

    If all else fails, you can try this extension to try and force Flash to load.

    If all that fails, maybe the site isn't using Flash. Don't know without a link. If it really is using Flash and you've tried everything else, and you use Opera Sync, download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation" and install. In that Opera if it works fine, then it's an issue with your normal Opera profile. If you enable sync in that Opera and it breaks Flash for you, it's an issue caused by Opera Sync and we can go into further detail to try and find out what setting Opera Sync is messing up.

  • There can be a "Click to enable Flash" icon/placeholder on a page where you click it to add the site to the allow list like you can do with the badge on the left side of the address field. But, you'll only see this placeholder on the page if the site actually tried to embed a Flash object. If it only tries to embed a Flash object after it detects Flash is installed and it gets the detection wrong, you'll never see this placeholder. In short, forget about the placeholder since it won't reliably show up. But, if you've never seen it, goto http://get.adobe.com/flashplayer/about/ for an example of what it looks like. Besides, if you add the site to the allow list, it should disable the placeholder and automatically allow Flash.

    Using Opera's built-in adblocker or another adblocker extension could interfere with Flash on a page. Make sure that's not the case. If you're using Opera's VPN or Opera Turbo, try without those on.

  • Thank you for the replies! Unfortunately, I tried every option you gave and nothing changed. Flash is working fine, it's just that I have to click the play button every time. Here's an image of what I'm getting:

    alt text

    I think it's exactly what the "click-to-play" option that is no longer available used to toggle. I have to hit those play buttons every time. It is set to not ask first in the settings and the site is on the allow list.

    Very perplexing...

  • @eagleheart said in Opera 55: Disable Click-To-Play For Flash?:

    Thank you for the replies! Unfortunately, I tried every option you gave and nothing changed. Flash is working fine, it's just that I have to click the play button every time. Here's an image of what I'm getting:

    Ah, okay. I misinterpreted what you meant by "click to play". Yes, Leo is correct. It's due to new Flash policies in Chromium. I'll see if there's a workaround.