Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Cannot Access Other Partition

  • Opera cannot access a partition which the Linux user can access.
    Eg, when i try to upload or download a file to that partition, Opera says:

    could not read the contents or /mnt
    error opening directory
    permission denied

  • The page you linked says to reset all settings to default.
    But, it doesn't say how to do that.

    This page gives instructions for Windows, but not Linux. I'm on Linux.

    How do i do that?

  • Still getting the same problem. i have done the following:

    Disable all extensions
    Disable the ad-blocker
    Reset flags to default
    Create a clean profile folder/directory

    did not Reset settings to default, cuz no instructions available. I cannot find operapref.ini.

  • @johnywhy In Opera for Windows there is an option in settings to reset them. I guess Opera for Linux would have the same.

  • @leocg said in Opera Cannot Access Other Partition:

    @johnywhy In Opera for Windows there is an option in settings to reset them. I guess Opera for Linux would have the same.

    can you share image? i don't see that.

    THX

  • NTFS

    It's an NTFS partition.
    My Linux is Ext4.

  • Solved.

    Problem was: Opera was installed on Linux with Snap. Snap applications are unable to access external partitions.

    Others have reported this issue.

    THX

  • Topic closed as solved. If in up until to a month the author needs the thread to be reopened, just report it. briefly explaining the reason.

  • Temporarily reopened by request of the OP.

  • My Mint 19 xfce doesn't give write-access external partitions by default. This fix will give your Linux write-access.

    This fix assumes you already have read-only access to the external partition. If you already have read-access to the drive, then your Linux has no problem with the partition format, whether NTFS, FAT32, or something else. Setting Linux-style permissions (chmod) on the external drive won't work if the drive is NTFS.

    Caution: Non-advanced users should not mount their Windows operating system disk in Linux-- you can break your Windows if you accidentally alter a Windows system file. In my case, the external ntfs partition i'm mounting in Linux is not my Windows operating system disk-- it's just my document storage.

    The fix is:

    • disable fast-boot in Windows, and do a full Windows shutdown (rather than "Restart")
      https://itsfoss.com/solve-ntfs-mount-problem-ubuntu-windows-8-dual-boot/
    • tell Linux that the current user is "owner" of the drive, by appending their uid to the drive's mount-options. (this will be in-effect only while Linux is booted, and will not affect your Windows):
      • In Linux, open a terminal, and enter id
      • Copy the uid. On my Linux, it's:
        uid=1000
      • Open Disks program.
      • In the left pane, pick the drive containing the external partition.
      • In right pane, click the desired partition.
      • Click the gear button, and pick Edit mount options
      • Find the textbox above the "Mount Point" box. Type a comma at the end of the text already there. Then paste. Don't alter anything that's already there. My final line looks like:
        nosuid,nodev,nofail,x-gvfs-show,uid=1000
      • Reboot Linux.
      • Done.for when

    This will give write-access to only the current Linux user (and no other Linux users). If you want to give access to all users in the same user-group as the current user, then instead of entering the uid from the terminal-command above, enter the gid. Eg:
    gid=1000

    If you don't have the Disks program, you have to directly edit a system configuration file, called fstab. Fstab file is found at: /etc/fstab. But again, if your Linux already has read-access to the drive, then you don't have to worry about the myriad of fstab options-- just append your uid or gid to the current fstab settings for that partition. More info:
    www.linuxstall.com/fstab/

  • more info on Disks application:

    https://wiki.gnome.org/Apps/Disks

    requires that you can run gnome software,

Locked