Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera Mail Spam Filter off but still moves mail to Spam folder

  • Just installed Opera Mail and I'm finding that it keeps moving the same set of emails to the Spam folder even though I keep marking them as not spam and constantly having to do so every time.

    Then, if I look at the Spam folder again in a few minutes after each time it does its check mail interval or if I close Opera Mail and open it - it moves all the emails back to Spam folder every single time without fail.

    I have turned off the internal filter (Spam - Properties) and also ticked "Disable local spam filter for this account (server-side filtering)". I have also set the correct Spam folder in IMAP settings.

    When I look at my email folders via webmail, the junk / spam folder is empty so there's nothing else I can think of on the server-side that is making Opera Mail repeatedly moving emails back to Spam folder every session.

    Just as I'm typing this, I can see emails reappearing back in Spam folder again...

  • @viewfinder The spam view learns based on the messages added to and removed from it. You may need to disable that feature.

  • Yes, right-click on All Messages/Spam in the mail panel and goto "properties". In addition to turning off the internal filter, you need to uncheck "learn from labeled messages" on the options tab. When you uncheck that option, in addition to turning it off, it should delete the learned rules (that are stored in the autofilter folder in the mail folder (see "Menu -> Help -> About Opera Mail" for the location)).

  • @burnout426 Hi, the internal filter is already turned off and "learn from labeled messages" also unchecked and the autofilter rules file I had already deleted yesterday.

    However it still continues to move same set of emails into Spam. I've just opened Opera Mail this morning since last night and it has just moved emails again while it was checking for mail...

    Not sure where else I can check but as all of the above has been set correctly, I may have to reinstall OM.

    Is there a way I can back up my accounts easily so I don't have to reenter all my accounts settings after reinstall?

    Thanks

  • @viewfinder said in Opera Mail Spam Filter off but still moves mail to Spam folder:

    Is there a way I can back up my accounts easily so I don't have to reenter all my accounts settings after reinstall?

    While Opera is closed. you can try to backup accounts.ini in the "mail" folder. Then, delete/rename the "mail" folder, start Opera so it creates a new mail folder and then close Opera. Then, replace accounts.ini with your old one. Then, start Opera. If that works, you still might have to retype your usernames and passwords But, doing things that way was never supported.

    It's better to delete both the roaming and local Opera Mail profile folders and start fresh. But, this time, don't enter any usernames and passwords when setting up your accounts. Instead, after they're created, go into each IMAP account's properties and choose to disable the spam filter for the accounts. Also, disable the internal filter and "learn from labeled messages" for "All Messages/Spam". Once you have all that done, go into each account's properties and enter the username and password for the incoming and outgoing servers. That way, Opera's Spam filter never has a chance to learn anything etc.

    If you still have the same issue, it's something with the server's spam handling. Either that or some spam IMAP keywords/flags that Opera set on the messages are still on there. You should be able to check the log to see if that's the case. If so, there might be some tricks to get those flags/keywords off of the problem messages.

  • @burnout426 Thanks for the info, I will try that now and update back here the outcomes.

    I'll try the quick method first and test for a bit and if that still doesn't solve it, I'll then do a full uninstall / reinstall and configure it from a clean state.

    I do disable local spam filter for each account individually so that it's all server-side. The emails moved by OM don't appear in the Junk folder in Webmail so it doesn't appear to be mirroring anything server-side but as you suggest, it could be a local keyword / flag.

    Fingers crossed!

  • OM still moving emails into Spam folder... I did enable logging and do see many FETCH entries:

    • 150 FETCH (FLAGS (\Answered \Seen $NotJunk) UID 175573)
    • 151 FETCH (FLAGS (\Seen $NotJunk) UID 175574)
    • 152 FETCH (FLAGS (\Seen $NotJunk) UID 175575)
    • 153 FETCH (FLAGS (\Seen $NotJunk) UID 175576)
    • 154 FETCH (FLAGS (\Answered \Seen $NotJunk) UID 175577)
    • 155 FETCH (FLAGS (\Answered \Seen $NotJunk) UID 175578)
    • 156 FETCH (FLAGS (\Seen $NotJunk) UID 175579)
    • 157 FETCH (FLAGS (\Seen $NotJunk) UID 175580)
    • 158 FETCH (FLAGS (\Seen $NotJunk) UID 175581)
    • 159 FETCH (FLAGS (\Seen $NotJunk) UID 175582)
    • 160 FETCH (FLAGS (\Seen $NotJunk) UID 175583)

    I'm still having to Select All and Mark as not spam each time.

    Will proceed to reinstall and try again cleanly...

  • Sadly still the same after reinstall. Will POP download those emails OM thinks are spam so they're no longer there. Hopefully once they're out the way it should be fine from this point on.

  • Just to update. I've downloaded the specific emails to a separate POP3 client and deleted from server. Opera Mail is behaving itself so far and looks OK. Not sure what was unique about those emails but now that they're deleted, Spam folder is remaining empty...

  • @viewfinder said in Opera Mail Spam Filter off but still moves mail to Spam folder:

    Just to update. I've downloaded the specific emails to a separate POP3 client and deleted from server. Opera Mail is behaving itself so far and looks OK

    Awesome!

    @viewfinder said in Opera Mail Spam Filter off but still moves mail to Spam folder:

    Not sure what was unique about those emails

    Yeah, not sure. Was most likely an issue with a flag/keyword.

  • @burnout426 Thanks for your help and advice, much appreciated. 👍🏼 Out of curiosity, do you know of any tips on troubleshooting flags and keywords or is it a complex task? Normally I like to troubleshoot and find the cause and fix rather than workaround them.

  • See https://stackoverflow.com/questions/14959461/how-to-talk-to-imap-server-in-shell-via-openssl and learn a few of the IMAP commands that allow you to select a folder and view/add/remove flags/keywords for a certain message. Then, if there's ever a problem, you can manually fix the problem messages. You can get openssl binaries from https://slproweb.com/products/Win32OpenSSL.html for example.

    Takes a little while to learn some of the stuff. You can also do it with Telnet, but if you make a type for a command, you can backspace to fix it and will have to retype the command all over again. But, Telnet is already installed, so you might find that easier.

  • @burnout426 That's brilliant! Thanks, will certainly have a look and try that if any problem emails ever move to spam again. Something different and new to learn!