Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Just installed Opera Mail (win 10, gmail account) and the Sent messages are incomplete

  • I have just installed the Opera Mail on Windows 10 for my Gmail account.
    I got all the Inbox mails, but the Sent mails are incomplete (inexistent after a certain date).
    My settings are:

    Incoming IMAP server
    imap.gmail.com
    port no. 993
    secure connections: TLS
    authentication: auto (AUTH PLAIN)

    Outgoing SMTP server
    smtp.gmail.com
    port: 465
    secure connection: TLS
    authentication: AUTO

    All these are in identical with the Mozilla Thunderbird which works fine.
    I would appreciate any help on this.
    Thanks in advance.
    Chris

  • I have noticed that there is an "Attachments" header with the following folders: Documents, Images, Music, Video, Archives.
    I do not know the purpose of this, but I noticed that the missing emails are in the Documents and Images folders, instead of the Inbox and Sent folders.

    Any clue why?

  • @chrscb Those should show messages that contains audio, video, etc attachments

  • @leocg
    Correct. Why these messages do not appear in the Sent or respective Inbox folders (they belong there)?

  • @chrscb said in Just installed Opera Mail (win 10, gmail account) and the Sent messages are incomplete:

    but the Sent mails are incomplete (inexistent after a certain date).

    Just in "All Messages/Sent"? Or, are they missing in the [Gmail]/Sent Mail IMAP folder view under the you@gmail.com access point too?

    On the IMAP tab in the account's properties, is the sent folder set? It should be automatically, but double-check.

    For "All Messages/Sent" and for "[Gmail]/Sent Mail", click on the "settings for this view" button on the mailing list toolbar and turn off threading. Do the missing messages show up then?

    Are you sure you let Opera fully sync all the headers for the first time. Maybe a check/send or check/all might help.

    You can also just try again. Close down Opera Mail and delete the "mail" folder (see "help -> about Opera Mail" for the location), start Opera back up and add the Gmail account again.

    Also note that for Gmail IMAP, it's just best to drag the you@gmail.com access point to the top of the mail panel and use that like you would in Thunderbird and forget about Opera's unified views. But, that's up to you.

    Also note that setting "make all messages available offline" on the "Incoming" tab in the account's properties will result in the best searching capabilities in Opera. It can take a while and use some bandwidth at first if you have a lot of messages though.

  • @burnout426
    Thank you very much for the time you took to have a look on my problem.
    The "All Messages/Sent" is fine and updated.
    The problem is in the "[Gmail]/Sent" folder. This is incomplete. The missing emails are located in the "Attachments/Documents" and "Attachments/Images" !!!
    I uninstalled Opera Mail, and using run cmd (DOS) commands I erased all "C:\Users\Chris\AppData\Roaming\Opera Mail" folders. Finally, I reinstalled Opera Mail. Same problem. All/Messages/Sent is updated and "[Gmail]/Sent" is incomplete. Missing emails are in "Attachments/Documents" and "Attachments/Images".
    It seems that to continue using the Opera Mail application I have to work with "[Gmail]/INBOX".
    I noticed that "Attachments/Documents" and "Attachments/Images" contain also some missing Inbox emails (not dublicate)!

  • @chrscb said in Just installed Opera Mail (win 10, gmail account) and the Sent messages are incomplete:
    Correction:

    It seems that to continue using the Opera Mail application I have to work with "[Gmail]/INBOX" and "All Messages/Sent" folders, which is inconvenient.

  • Messages in the "Attachment" views should have no effect on whether they're shown in other views or not. Weird.

    [Gmail]/Sent"

    Do you mean "Sent" or "Sent Mail". It should be the latter. Check "IMAP folders" to make sure you're subscribed to the right one. Maybe it is only "Sent" depending where you are. In U.S., it's "Sent Mail" though. Also, on the IMAP tab in the account's properties, it should be "Sent Mail" that's set as the IMAP sent folder.

    Either way, click the "settings for this view" button for the sent message list and make sure "show sent" is checked. Make sure "show duplicates" is checked for now too. If that doesn't help, does checking "show hidden" help?

    Note that for Gmail IMAP, there are 2 copies for each sent message. One copy is from "[Gmail]/Sent Mail". The other is from "[Gmail]/All Mail". The latter copy isn't treated a sent message and isn't controllable by the "Show Sent" option for a unified view. To work around that issue, create a label named "Sent" with a rule of from contains you@example.com, apply it to all messages and set the label to "hide these messages from other views". Then, the copies from [Gmail]/All Mail will be controlled by "show hidden". Should have nothing to do with your issue, so, just an FYI.

  • At mail.google.com in the IMAP settings. make sure you have "Do not limit the number of messages in an IMAP folder (default)" set too.

  • @burnout426
    Thanks again for your reply.
    I am not located in the US. I am in Athens, Greece.
    I am confused now.
    My file structure on the left panel underneath "Compose"is:

    • [GMail] (my email@gmail.com with the following folders)

    • [Google Mail] (group header)

      • All Mail
      • itemBin
      • Drafts
      • Important
      • Sent Mail (this is complete Sent; all sent emails)
      • Starred
    • Deleted Items (same indentation as {Google Mail])

    • Drafts

    • INBOX

    • Sent (incomplete; missing Sent emails)

    • Trash

    [All Messages] (with the following folders)

    • list itemUnread
    • Received
    • Pinned
    • Outbox
    • Sent (incomplete; missing sent emails)
    • Drafts
    • Spam
    • Trash
      ===================================================
      I do not know how you can see the indentations, but you can follow the structure by looking your Opera Mail.
      The "[Gmail]/[Google Mail]/Sent Mail" and "[Gmail]/Sent" mails are different!!!
      You don't have to spend more of your time on this. Thanks for your effort. I Appreciate this. Shit happens. They just hit the fan in my email account. There must be an explanation but ...
      Take care.
  • It looks like you used/use an IMAP client (perhaps a mobile one) that doesn't select Gmail's specific special folders for Sent, Spam, Trash and Drafts etc. by default, so it create ones in the root of Gmail with the names the client supports by default. It also looks like maybe "Sent" is set as the IMAP sent folder in Opera instead of "Sent Mail".

    Ideally, you should go to mail.google.com and delete (or at least "hide from IMAP"), the Drafts, Sent and Trash labels that are in the root. You should also delete (or hide from IMAP) the "Deleted Items" label. Of course, move any messages in those to the proper folders first.

    Then, make sure every client you access Gmail IMAP with you set the Drafts, Sent, Spam and Trash folders to the proper Gmail ones so that those clients don't cause the wrong ones to get created again.

    I am in Athens, Greece.

    Ah, that's why it's [Google Mail] instead of [Gmail] and itemBin is trash I guess. Opera Mail itself should select those properly, but double-check on the IMAP tab in the account's properties.

  • @burnout426
    Thank you again for your effort.
    I have tried everything you have suggested. In vain.
    I have not used IMAP of my own choice. I let it install on its own and choose automatically the gmail root folders. I was not asked at all to intervene during the process of installation. I have performed two installations after a clean uninstall. I will have to digest and accept that, or return to Mozilla Thunderbird or Microsoft Outlook.
    Take care.

  • @chrscb FWIW, it works fine with my GMAIL IMAP account.

    What you're seeing is weird. If "[Google Mail]/Sent Mail" has all the messages it's supposed to and it's set as the IMAP sent folder on the IMAP tab in the account's properties, and "Show Sent" is checked for "All Messages/Sent", "All Messages/Sent" should show show the same thing that "[Google Mail]/Sent Mail" does.

    The only bug you might bump into with sent messages is if you have threading turned on for the sent list and the sent message is the first/only message in a thread. This can cause some sent messages to be hidden. Turning off threading and unchecking and rechecking "show sent" for the sent list should fix that.

    But, yeah, sounds like you're tired of messing with it. Using Thunderbird will be better anyway since Opera Mail stopped being developed years ago.